Extensions and Trays Disappeared Randomly

Hi there! I recently made the switch from 2023 SketchUp to 2024 and it went great! I was operating the 2024 version seamlessly for a couple of weeks… when all of a sudden, opening a new project completely wiped all my trays and extensions. I’ve been reading into some of the other ways this issue has presented itself but I can confirm that all of my extensions are installed and correctly located in the plugins folder deep within my file directory. Moreover, my extensions were there this morning, I opened an new project that someone had sent me through dropbox, now all of my sketchup projects (no matter the version) have zero extensions displayed and no trays are turned on. I’m very capable of setting up ALL of my extensions and trays again, just hoping there was a way I could revert! Thanks

Since it did work and doesn’t now, it would be useful to figure out what changed on your computer. It’s unlikely that opening a SketchUp file would do it.

First thing I would try is repairing the installation of SketchUp. Close it, find the downloaded installer file, right click on it, choose Run as administrator, and then, when the option is presented, choose Repair. After that do a cold reboot of your computer and see where you’re at.

Please update your forum profile. It’s a couple of years out.

Done! I’ve done a repair and a reboot… I’m still not seeing my extensions. Oh, and I updated my profile :wink:

1 Like

Do the extensions show listed in Extension Manager?

Are you sure that you had installed the extensions in SketchUp 2024 before?

Thanks for updating.

Yes & yes! I’m struggling to find some proof (either an email i had sent or a snip) because I’d alos like to use that as a reference in the case that I need to setup my extensions by-hand again.

and I had a very large project that I submitted last friday - that’s my only sort of proof that i was using the extensions consistently

I just tried opening my 2022 version and it saved all of my old extensions.

What do you see on the Home page of the Extension Manager?

Extensions are installed separately for each SketchUp version so the fact that they show in SketchUp 2022 isn’t really important to the issue at hand.

Is it the extensions or just the toolbars for the extensions that are missing? If the latter, that can happen if SketchUp wasn’t installed correctly or if the .json file that stores the state and positions of the toolbars was deleted.

Sorry for the confusion - just the toolbars are missing. I feel like i had previously said that my extensions and trays are not displaying but I know they are still downloaded and installed. In other words, I think the .json file is likely the solution to this issue.

You did but did not say extension toolbars.

That file is important but unfortunately, if SketchUp wasn’t installed correctly (right click – Run as administrator) when it was first installed, Windows might not allow the .json file to be written or at least written completely.

Okay! I feel like I correctly installed SketchUp the first time around - is there a way to restore the .json file? If it means anything, I restart my computer before I leave the office everyday and everytime I opened SketchUp the next morning, the toolbars were stored correctly.

So you right clicked on the downloaded installer and chose Run as administrator the first time you installed it?

I wouldn’t count on it. You could look at it in your User/AppData/Local/SketchUp/SketchUp 2024 and see what the current date of it is. If it’s Modified date is after the toolbars went missing I think you’ll need to set them up again. If you do that, create and save a simple model file to ensure the file gets written.

Note: The User/AppData directory is a normally hidden folder. You can make hidden folders visible in File Explorer though.

I believe I did install SketchUp 2024 with administrator privelages and my .json file is time stapmed @ 1:18 today, which should be correct.

Having administrator priveleges is not the same as right clicking on the installer and choosing Run as administrator.

Then it’s been overwritten from when the toolbars were being displayed so nothing to reover. You would need to redo the toolbar placement and then save a model file to get it to update.

Sorry Dave - I’ll stick to simple yes or no answers since I seem to be causing confusion. What I was trying to say is that ‘yes, I installed SketchUp by right-clicking and running as administrator’ (i.e. i ran the installer with administrative privelages enabled - that’s how i’ve always interpreted it). And by the sounds of it, I’ll just setup my ‘toolbars’ & trays again, then do a save so my json. file gets updated. Can do!

Last thing, how can I be assured that when I open that same project file (the file I recieved through dropbox as previously mentioned), the same thing won’t happen again?

As I wrote in my first post, it’s not likely that the SketchUp model file had anything to do with the toolbars going missing. I guess I can’t make a guarantee but I guess I would set up the toolbars and ensure the .json file gets updated. Make a copy of it some place to be safe. Then open SketchUp and open the model file. See what happens.

Make sure you are not opening it directly from DropBox. Instead, download it to your computer and open it from there.

Awesome! Thank you so much Dave!

I’ll give that a shot, but yeah - I had a similar concern that opening the file directly from dropbox is the source of the issue.


You’re welcome.

Actually I wouldn’t expect opening the file directly from Dropbox to have any impact on toolbars and the trays. The reason for my recommendation to download the file to your internal drive first is to avoid corrupting the model file. Many users have found that working on files saved outside of the computer resulted in the files becoming corrupted so badly they cannot be recovered.

Oh geez - thanks for the heads up. I like saving the files to my desktop beause it seems to make the file operate a little smoother and like you said to avoid corruption. I did manage to get my toolbars set back up and saved my .json file to my desktop and external hard drive (definately don’t want to go through that again… for the third time). It breifly came accross my mind that I could search through my external hard drive to try and find the old .json file but for some reason my external hard drive does not make backups of app data. I really thought I could dig and find it but I don’t think there is anywhere else an old .json file may be located - unless you have other suggestions.

Now that I have a much better understanding (thank you Dave!) & my toolbars are back to where they should be (i’ve made backups of said .json file)… I think I’m happy!

1 Like

Would you like me to mark solution anywhere is this conversation?