Extension Warehouse download attempt crashes SU

Hi all
I’ve just installed Make 2016 (30 day pro trial) on an Asus Zenbook Windows 10 64 bit. I tried to install Profile Builder 2 (Trial Version) from the Exension Warehouse 4 times in a row. Each time I click on “Install Trial” Sketchup and the Warehouse dialog just disappear. No messages, nothing, everything just vanishes.
Ouch.
Does anyone have any ideas?
Thanks
Elliot.

Update
I’ve tired all of the following and still have the same problem

  • Turned off Kaspersky - no change
  • Followed the instructions at http://help.sketchup.com/en/article/3000180 to resolve a similar issue which occurred when upgrading from Sketchup 8 to SU 13 - same result
  • I have tried downloading other extensions and now understand that the problem is overall. The result is the same. As soon as I get to the download page for any extension SketchUp vanishes after a couple of seconds. It makes no difference whether I click on the download or “trial” button.

Am I the only one out there with this problem?
Thanks
Elliot

Can you donwload an extension with your webbrowser and install it manually in the preferences?

Profile builder 2 does not have a download button in he Warehours - only a link instructing me to do it from within SU.

I have confirmed that this issue also occurs on the 2015 x64 version on Windows 10 Pro x64.

SU, like other programs, uses the default system browser - in this case IE. Is IE updated to the latest version and all IE browser cache cleared?

Hi cata
In fact I setup chrome as the default browser. but I thought that you had put you finger on it so I just setup IE 11 as the default. I did not clear the cache because I haven’t used it for anything. Unfortunately the problem is still there. I now get the Windows message stating the the SketchUp application has stopped working which I didn’t with Chrome. However the end result it the same.
Elliot

Just deleted the cache and same result as Chrome.

FWIW, it doesn’t matter what you set as the default browser. SketchUp uses IE on Windows and Safari on Mac for web-based operations.

As Dave indicated, you can still have Chrome as your default. But program developers work with tools provided by your OS developer. So people still need to maintain the browser provided by the OS.

IE still accumulates a lot of stuff even if you don’t use it. I have Chrome as default browser too. Run CCleaner - a great free app - sometimes I remove more cached garbage from IE than Chrome.

While you’re at this basic maintenance, update your graphic driver. I see that Zenbooks use integrated Intel graphics. Are you able to use hardware acceleration - in SU, check Window > Preferences > OpenGL? Is there any difference if you disable hardware acceleration if it was enabled?

Ahumm I use Firefox in windows and it lets me do what ever and I use win 7-1 inside of Virtual Box . .Linux is my base O/S !

[quote=“lynne, post:12, topic:18869, full:true”]
Ahumm I use Firefox in windows and it lets me do what ever and I use win 7-1 inside of Virtual Box . .Linux is my base O/S !
[/quote] I too use Firefox on Win 10.
But it remains a fact that for any web based dialogs etc SketchUp will ALWAYS use Internet-Explorer on PCs, or Safari on MACs.
This is quite separate from whatever web-browser you might have set up as a default to open html etc, and which you might use ‘day-to-day’.
If you are using some kind of emulator with a different base OS, it’ll still use IE - v11 is current, ensure you have that updated/installed…

1 Like

From the Help Files on PC: “To connect to the Internet, SketchUp uses Internet Explorer even if you have a different default browser.”

Hardware acceleration was checked so I unchecked it to try something different but no joy - same result although it take a few seconds longer for everything to vanish.

I am able to download models from the 3d warehouse so the problem is specific to the extension warehouse.

Did you clear your IE cache?

SU developers often check into the forum, but this is a holiday weekend… We’re trying to cover the basics here. Too bad there’s no SU bugsplat for them to look up. Posting any error message you’re getting (take a screen shot), like that Windows error message, may help.

Well sorry but when I click something for sketchup firefox runs and gets it . . I removed a lot of the stuff in win 7-1 which they put back into win 10 and added more stuff to get info from your computer . . You can remove a lot of that stuff and got to do some searching on line and do what it says to do and things just work better . . Windows ie MS does not like it art all . .

Hi cata
There’s no bugsplat - but I wonder if there’s anyway to start SU with a switch to create a debug log? That might be helpful.

Haven’t heard of any such debug log…

Have you deleted the IE cache of c-r-a-p?

A few more things to test.

After doing a lot of the ‘cleaning’ it wouldn’t hurt to restart the computer to clear out the cobwebs…

BTW I did clean out the IE cache a while back.

I’ve just rebooted and that did not help. I then, on a whim and mostly because it’s been behaving so badly on my Android I quit out of Skype, And for some reason that did make a difference … up to a point.

I’m now able to stay in the warehouse dialog a bit longer and after I click on the Trial download button for PB 2. I get a brief please wait message But alas SU then does the same vanishing act.