Unable to Download STL plugin

I click on download and it makes me login. I login and it gives me the install option. I click on install and it goes back to the main page to search for plugins. I have tried in multiple browsers to download. I have tried using Chrome and also the actual application. I have tried uninstalling and reinstalling. I have tried different versions 15 and 16. No difference. Is there somewhere other then Extension | SketchUp Extension Warehouse where I can download that file so I can manually import it.

im having the same issue, is there anyone who could shed some light?

I’m having the same issue, I thought maybe it was something I was doing wrong?

Did You try other plugins? SketchUp Plugins | PluginStore | SketchUcation

Mac or PC? Can you download from a browser and install from that download? I just tried it and it worked for me. Can you logout and back in? OK, @andrew.bigford andrew.bigford you edited your comment, so I’ll edit mine. We can’t repro this in Win 10 in SketchUp 16.

@v2giancdoria, you say OS version is Windows, but what version of Windows?

@MatthewS, I tried Win7 and it worked there as well.

We’ll assume you got it working unless we get more information from you on it.

<Post must be at least 20 characters>

Hi Barry, I did not get it to work. I can not download from a browser, I tried multiple extensions, none of which work. When I click the download in the browser (both Chrome and IE11), It gives a redirect message and returns to the Extension warehouse home screen. The same thing happens when I try to install from inside sketchup. I thought it could be my computer, so I just tried it from my work computer, same thing happens. I am not sure what to check for now.

Hmm… I tried again in Edge on Win10, and it ran the virus scan, then gave me this window, and all worked. We’ll keep digging.

hi i have same issue on mac sketchup make 2016. it just keeps going in a loop when i try to download keeps asking me to log in then i do and back to the beginning

im in mac can’t download any extensions only clicking install/download once then get logged out have to log in again and again

Lynne, please stop. You’ve been warned before about off-topic posts.

I’m a Windows 10 user (64 bit) having same problem with trying to install Solid Inspector 2 and Skalp. Tried direct from Sketchup and using Edge browser and Chrome browser.

I’m having the same issue with windows 10


It is not still working. THis is for PC. When I click on Download it takes me to the google login page. I login. It takes me back to the page where you can click on the button to download. I do that and it logs me out of the program and sends me back to the main 3D plugin page.

I also tried it on my Surface Pro 3 with same results. Is the download file not available somewhere else?

It’s open source and on github for anyone to contribute to.

I got on Github and downloaded the ZIP file there. What file in it is supposed to be imported? Sketchup plugin importer wants a .rbz file. But the only thing I have found in that zip file is .rb files. I tried adding a Z and seeing if that made any difference but it has not.

change .zip to .rbz…


Change the .zip to .rbz and use that with the install extension button in preferences.

Or read the forums - [URGENT] STL file for 3D printing