Can`t find STL Plugin in "Extensions" after download


#1

Hello,

i´ve just downloaded the STL plugin from the Sketchup Website and was hoping to install the .rbz file via clicking on
Window-> Preferences -> Extensions
and then selecting the plugin (named sketchup-stl-2.1.7.rbz).

Sadly, I cannot find any trace of it there, neither the actual file name, nor something else that says STL.

I´ve done this kind of extension-installing before, back when I downloaded the SVG plugin and it worked just fine, so I´m fairly helpless now.

I hope someone has an idea on how to fix this Problem.

Thanks, Fred


#2

Are you downloading it directly from the Warehouse to your computer or accessing the Extension Warehouse within SketchUp? If the former, download it again and pay attention to where it gets saved and the file name. If the latter, it should install directly and you won’t need Install Extension.


#3

I´m downloading it directly from here: https://extensions.sketchup.com/de/content/sketchup-stl

I can´t access the warehouse from within sketchup, because my version is too old.
´ll try upgrading and then access from within tomorrow, if it actually installs automatically, that would be great!


#4

I get stuck that way some times. Have you tried the widows explorer along with a wild card search. If you have libraries setup on your machine it will go quicker but it can take some time with the large drives.


#5

OK. So I guess the key is to pay attention to where it downloads to when you click the Download button. Or do as Mac suggests and search with a wildcard. Maybe *.rbz.


#6

Just look at link and it states it is the file menue not extensions?


#7

After it is installed, you find it via File/Export, IIRC. Not at my computer so can’t check - it might possibly be File/Save As…

STL should now be one of the options you can select to choose the type of file to export or save in either case.


#8

So downloading the newer version of SU somehow doesnt work… So I´ll have to try some other way.

I can find the file in my download folder, but where should it be downloaded to, so that I can find it in the extensions window when I open Sketchup?

What would searching with a wildcard do, other than finding it? I´m not really familliar with all that…


#9

How doesn’t it work?

Your machine won’t run it? Bugsplat on startup? Won’t start at all?

In that case, in SU 8 (which is what your profile says you are using) go to Window/Preferences/Extensions [Install Extension] then Look In … Downloads for the .rbz file.

If your version of SU 8 isn’t the latest one released (M2) this won’t work… The STL extension might not work anyway in v8 if it uses a later version of Ruby than the one SU8 uses.

See what version of SU you have - look in Help/About Sketchup… My version 8 says it is 8.0.151 58 which AFAIK was the latest version 8 M2 release.


#10

Blockquote In that case, in SU 8 (which is what your profile says you are using) go to Window/Preferences/Extensions [Install Extension] then Look In … Downloads for the .rbz file.

I thought I could only click on [Install Extension] when I have checked a plugin in the shown list.
But it actually opens a window in which I can then select the plugin in my download folder.

So simple…and it worked. Thank you so much!


#11

Oh yeah, Sketchup 2017ndownloads and installs but when I go o start it, it simply does nothing. Which is odd, but it doesn´t really mater to me, I like using Sketchup 8, if I want to use the newer version at some point, I´ll start dealing with it then,


#12

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.