Extension Warehouse won't install, logs me out and returns to home page

I can browse the extension warehouse and sign in but if i try to install any extensions it just reloads the EW homepage and logs me out. I’ve tried clearing cache in safari, completely uninstalling sketchup and all related folders and reinstalling, ending the 30 day pro trial, and none have given results.
It does seem to allow me to update the preinstalled trimble connect plugin under “My Extensions” but otherwise nothing.
3d warehouse works fine.
i can install other extensions from other sources manually with no problems.

Any ideas why I’m having this problem?

using the most current sketchup
MacBook Pro
Intel Core i7 3.1 GHz
16 GB ram

one thing that may mean something, the first time i login i get a red banner on EW homepage that says:
“The Form has become outdated. Copy any unsaved work in the form below and reload this page.”

See this thread: Unable to Download STL plugin

We can’t repro this. Can you post a screenshot of “The Form has become outdated”?

Im sorry what do you mean by “we can’t repro this?”

repro = reproduce…

is there a form if you scroll to the bottom of the page?

john

Ok i see. There is no form at bottom of the page, its the standard homepage other than the banner.

Ive tried a couple other things. Ive tried from same MBP in bootcamp win10 64bit SU2016 and still have same logout loop issue. Ive also tried SU2015 in OSX with same issue.

In OSX sketchup 2016 I can install extensions from the sketchUcation extension store plugin just fine.

It really seems that it might be a site or authentication issue. Im stumped.

did you try ‘reloading’ the page? [Right Click >> Reload Page]

john

oh yeah for sure, its just same problem.

is *.sketchup.com in your list of “Trusted Sites” ?

Control Panel > Internet Options > Security (tab)
Highlight “Trusted Sites”, then click the “Sites” button.

im on OSX is there a similar “trusted sites” on mac?

Barry,

I created a generic gmail account and signed into EW to see what would happen, it still does the logout loop that we have been discussing. if you would like to try and login with this account to see if you can reproduce this glitch i can give you this login. let me know if you want to try this.

Thanks for the info. We’re efforting, and can now reproduce this: Unable to Download STL plugin

Sorry, do not know. It would be in the Safari settings, I’d guess.

I am having a similar problem. at first when I attempted to log into SU, I could log in, chose an extension to download but on hitting the download button I was instantly logged out with the following…Authentication Error ! Something went wrong during the authentication process. Please try signing in again. …
Now the problem has morphed so that now when I click to log in I get the above error immediately. I have tried unistalling/reinstalling, put Explorer11 to all defaults, deleted cache/hist after every attempt, multiple browsers… nothing works have read past forum conversations but have not come any new ideas. John

Read Unable to Download STL plugin? The problem has been ID’d and in process of being fixed.