Error Message when downloading from Extension Warehouse

I am unable to download and install anything from extension warehouse. I am running win7 with sketchup make 2016. I attached an image of the error when I logout and log back in to sketchup. Plesae help. Thank you.

Why do You look for Extensions in the 3d_WARE_house?

Try this:


Thanks for the response. I do use the site you just recommended but I still
get the same error. I can download from files from 3d warehouse, but not
from the extensions. Can you help me with this. I already tried the
following :

  1. Run Sketchup as Admin
  2. Reduce security settings of IE to medium, it is as low as it gets.

Thank you.

Sorry, I am using Google Chrome and don´t have such problems.

@miller, actually, everyone uses the OS’s web browser when accessing the web from inside SU - so that’s either IE or Safari. The javascript used by SU also come from the system browser too.

Update Windows and IE?
Clear IE cookies and cache?

“…when accessing the web from inside SU…” - right, and that´s to avoid.

no, they are the default portals used internally, SU has no choice…

if your IE or Safari don’t work, many other things will also not work…

you can’t use your other ‘browser’ for Get Location or Photo Texture or any of the many Extensions that need web access…


Hi guys,
Thanks for all your responses. There is one thing I have not tried to do
though, how do I clear the sketchup cache. I cant’t find the directory that
was shown in one of the forums I read. Pleas help. Thank you.

In IE, go to Settings (upper-right corner) > Internet options > Browsing history.

I like to use the app CCleaner to clear out all sorts of c-r-a-p. The free version is fine. And under options, you can pick out cookies you want to preserve.

still not working , i cleared cache in IE and Chrome, from the beginning of time. Here is the error I am getting when trying to download plugins.

All extensions I wanted and which are offered by the extension-warehouse or sketchucation I downloaded with CHROME outside of SU.
A small overview of my plugins-folder :

You might try some of the actions I had to take to solve the same issue. Look for wwilson9," Opening Extension Warehouse in SUMake16. "