Skectchup vanishes after loading any download page at the Extension Warehouse


#1

Hi all

I’ve just installed Make 2016 (30 day pro trial) on an Asus Zenbook Windows 10 64 bit. I have tried to install Profile Builder 2 (Trial Version) from the Exension Warehouse. Each time I click on “Install Trial” Sketchup and the Warehouse dialog just disappear. No messages, nothing, everything just vanishes.

I’ve tired all of the following and still have the same problem

I have tried downloading other extensions and now understand that the problem is overall. The result is the same. As soon as I get to the download page for any extension SketchUp vanishes after a couple of seconds. It makes no difference whether I click on the download or “trial” button.

Does anyone have any ideas?
Thanks
Elliot.


#2

Don’t double post your question.


#3

Hve you tried down loads without using Sketchup, I just downloaded the free version w/o using SU and Dl worked but, have not tried to install /don’t want to do that. The ware house builder 2 download seems to show DL via SU but, you can try others and see if you have same problem.
You will have to log in to ware house.
Update you can only install trial version within sketch up


#4

Same issue on Windows 10. Tried all the recommended fixes such as clearing cache., Also tried setting IE as default rather than Edge. Crashes every time.


#5

It’s clear that I’m not the only user being affected by this. I’m waiting for a response from the developers.


#6

Sorry about the double posting, I’m new to the forum… Is there anyway to merge the posts?


#7

I was going to start a new topic about this thinking it may get more attention but your topic fit my exact probelm. Well, ALMOST my exact problem…

This is happening to me and another guy I work with, when i open the extension warehouse and then try to go to a download page, Sketchup just vanishes.

I have the engineering toolbox plugin installed and when i load that plugin Sketchup vanishes.

No bugsplat, nothing, just gone.

Both of us have recently gone up to windows 10 and we both are on company laptops so we both have the same virus protection etc.

I am running windows 10 Pro 64bit. My machine has an Nvidia card and the intel Quatro K1000M
8 gig ram

I think that the engineering toolbox uses Java to communicate back and forth and I feel that is where the issue is but that is just a “feeling”

i do not know how to tell windows to use IE and not Edge, if that is even the issue.

I have done a clean install of SU 2016 with NO plugins. Same result
I have removed SU 64 bit and installed 32 bit Same Result
I removed 2016 and installed 2015 64 bit Same Result

Java was just updated to latest version Same result

Thoughts?


#8

Irrespective of your default browser set up on a PC SketchUp’s own dialogs will use Internet Explorer.
The one shipped with Win10 should be v11 ?

Check your Internet Options Control-Panel.
It should not be set up to be too restrictive [i.e. Security level <= Medium].
Also check that nothing in its Advanced options looks too restrictive or out of phase…

Also check your Windows Firewall is set up to allow SketchUp unrestricted access…


#9

Yes the IE in Windows10 is IE11.
11.20 to be exact.
I went in to the options and changed security from Medium/high to Medium Same Result

I looked at advanced options but didn’t see anything “out of phase” but I wonder if I would have recognized it.

I turned OFF windows firewall and did a full restart of the computer. Same Result

Most Extension Warehouse pages cause it to crash as does running the Engineering Toolbox Extension.

The other fellow that is having the same issue has done the same tests with the same results.

thank you for your thoughts though. I will try anything as this is a huge problem for my work.


#10

Does this mean some ok or not?. I get message you think problem is related to Engineering Tool Box so if you remove it does it run ok? If you remove and then reinstall check file properties first and make sure unblock is checked. Done at that level will unblock all the associated files other wise must be done one at time.
Have you tried to regress back to state before you loaded w10? I know early on once you installed you cannot go back? Early one MS was also using user PCs as servers to help distribute W10. Don’t know if they have stopped that.
Good Luck
I have W7 and it does not show the elevated admin account login by default.
FYI for W7 www.sevenforums.com/tutorials/507-built-administrator-account-enable-disable.html
How was W10 loaded? If you did that under your profile and security permissions ok.
Same for W10 http://www.tenforums.com/tutorials/2969-administrator-account-enable-disable-windows-10-a.html


#11

Some pages in the Extension Warehouse load. some cause SU to crash.

Even with NO plug ins installed the Extension Warehouse causes SU to crash.

Even if I go back to SU2015 it crashes.

It is a company computer and they do not want me to go back to windows7

W10 was loaded as an upgrade to my Windows 7 pro. All of my programs and settings should have remained.


#12

TIG - I do have IE 11 setup with medium security. The firewall issue occurred to me yesterday so I added new rules to allow SU to have complete access. That didn’t help so I then turned off my virus protection and the Window firewall none of which unfortunately made a difference
Thanks for the suggestions.

I’m considering going back to my old Win 7 laptop temporarily just for SU but that’s not really a good alternative for many reasons.

Elliot


#13

HI Blastfurnace
Thanks for all the testing, I’m sure you’ve saved me some work. I really do think we need some help from Trimbal.
Elliot


#14

Yeah, I have the email for a guy at engineering Toolbox and I emailed him. Hopefully when the world goes back to work tomorrow he will see it and have an idea.

Certainly would be nice to have some input from Trimble. I

I have shut off everything I could and changed every setting I can think of. Changed every video driver but I really don’t think its video.


#15

UPDATE: To review, my Engineering Toolbox extension was causing the same behavior, it would load a window then a second later SU would vanish. Same thing happens when I go to certain download pages in 3DW.

well I sent an email to a guy at Engineering Toolbox website. He replies “Ok its fixed.” and now when I run the ETB extension it DOESN’T crash my SU.
So! I have asked him what he did. I hope he tells me and we can pass it up the chain.
Loading those certain download pages STILL crashes my SU so its something that
can be fixed on “their end”

 To be continued.....

So the saga continues…
turns out that ETB’s “fix” isn’t a complete fix. Many of the interconnected pages still cause it to crash SU. BUT it is an improvement. I received a reply from ‘my guy’ and he said.
The problem was caused by an “iframe” embedded youtube video and it was introduced with the latest Windows 10 upgrade. Windows 10 and the Engineering ToolBox extension (with the video) worked fine before the upgrade.
The Extension Warehouse use the same WebDialog feature to deliver the user interface as The Engineering ToolBox - and the Extension Warehouse will now crash Sketchup if a page with an embedded video opens.
A work around until Windows 10 (or Sketchup?) is fixed - is to disable iframed videos in the warehouse (Sketchup team and developers) or download the extensions from the warehouse with a browser - and install them manually (users).
So as more people get the “upgrade” to windows 10 more people will experience the crash.

  I am finding that my extension causes the crash, Still, about 60% of the time.

Extension Warehouse download attempt crashes SU