Esc key functionality


#1

With an entity selected, I used to be able to engage, say, the Pan tool, and then by pressing the Esc key, return to the still selected entity. Not any more, darn it! Beginning with SU 2014 (I think), this functionality was removed, so that now the entity has to be selected all over again. It sounds like a small thing, but it’s an irritating waste of time.


#2

Why not use the center mouse button to access Pan in LayOut? when you let go of the button, you’ll return the the tool you had. It’s the same as using the CMB in SketchUp except that Pan is CMB+Shift because the CMB by itself is Orbit. That would save you more time than stopping to pick the Pan tool or switching to it with a keyboard shortcut.


#3

No CMB, alas, on the Apple wireless mouse


#4

Ah… You ought to get yourself an inexpensive Logitech wireless mouse. It would make working in both SketchUp and LayOut a whole lot more efficient. And if saving time is a priority as it sounds it is, a $30 mouse with a CMB would be money well spent.


#5

Fair enough, but on the other hand, why couldn’t that simple functionality be restored? A three button mouse might be desirable but I don’t see it should be necessary.


#6

I could add that it’s one of several instances of disparity between Layout and SketchUp (where the Esc key functions exactly as it used to in LayOut). Another that comes to mind is the seemingly nonsensical necessity of holding down the Option key to copy an entity, instead of simply tapping the key as in SU. But I guess I’m in danger of broadening the discussion beyond its topic heading.


#7

I didn’t say that the functionality shouldn’t be available. Maybe it
should. Maybe they shouldn’t have changed that functionality. It’s just
never been an issue for me and I’ve never seen anyone even mention it
before. I only mentioned the three-button mouse because you brought up the
time it takes to make tool changes. The three-button mouse has been a key
tool for using SketchUp since long before LayOut was thought of.


#8

The same could be said in defense of any handicap you might wish to impose on yourself. That is, I suppose you could work the program with your feet rather than your hands to prove a point, but you’d be making it unnecessarily hard on yourself. Likewise the mouse.

You may notice that a three-button mouse is listed as part of the recommended hardware configuration. Why would you scoff at that any more than at the recommended video card?

-Gully


#9

Right, clearly time for updated prestidigitation skills. Obviously quicker than begging for a bug fix that bugs no other body. No scoffing here, mere ignorance and parsimony: recommended hardware configuration? what recommended hardware configuration? I’m sure I need a new video card, too. Not to speak of a new computer. Thanks for the tip about the feet. I’ll try it the other way.


#10

The Knowledge Base article (maybe they’re calling it Help Center now):

Hardware and Software Requirements

I salute your sense of humor.

-Gully


#11

Ooh! I haven’t had a good parsimony pie in a long, long time. Some ripe parsimonies, some eggs, cinnamon, cream.

:smiley:


#12

I have never needed it, but it works as described by dom on my PC. Starting a push-pull operation (for instance), selecting the Zoom tool, zooming and pressing Esc returns me to the incomplete push-pull command. Does it work for any Mac users?

(I moved the topic to the Technical problems category)

Anssi


#13

Anssi, it works as it always has in SketchUp on Mac but the OP was referring to LayOut. Pressing ESC to escape from panning and back to the previous tool doesn’t work like it used to some years ago. I see the difference he refers to between LO2013 and LO2016.


#14

With one-button mice or track-pads you can give a try to the following…

  • In SketchUp: cmd-ctrl drag to orbit, cmd-ctrl-shift drag to pan.
  • In Layout: both will result into a pan.
  • (and of course, scroll with two fingers to zoom)

These are the tips coming from SketchUp (link - search in the text for ‘one-button’).

Worked surprisingly well for me with my laptop’s trackpad, in combination with the three fingers gesture to drag. With the time, I even seem to make less use of my portable 3D mouse… I think because that allows to keep hands close to the keyboard and access short cuts more easily.

And it makes it possible to work on a sofa.

I am aware that sofas do not belong to the recommended hardware requirements, though that can make sense if (like me and maybe others) you want to use SketchUp in your spare time or on the go.


#15

Your instructions aren’t exactly right. It’s control-command-drag to orbit. Also, once you have started orbiting you can release the keys, and you can toggle to panning on the fly by pressing shift.


#16

Yes, thanks a lot and apologies. Now I edited my post accordingly for readability purpose.


#17

Seems these instructions are PC-specific? Neither the manoeuvres described here nor their subsequently edited/corrected version work on my Mac.

Of course, I guess it could be because I have the wrong sofa.


#18

Must be your sofa :sweat_smile: This keychord works on my MacBook Pro


#19

keychord – I like that. Still doesn’t work, though, arpeggiated or no. Wrong sofa and wrong Mac, I guess.

Wasn’t this thread supposed to be about Esc key functionality? It’s sunny here, I’m escaping outside before I have to explain why I still don’t have a 3-button mouse.


#20

That was meant for a Mac, maybe useful to know before considering using a 3-button mouse - that’s why I posted this, but I agree this does not solve the esc-key issue you mentioned. Btw I’d suggest this post to be reclassed under the Layout rather than the SketchUp category.

The link I provided to the SketchUp help center gives more detail, quote:

On a one-button mouse: If you use Mac OS X, press and hold the Control and Command keys while clicking and holding the left mouse button.

(sic)

I happen to play a bit of piano, maybe the reason why I am more receptive to keychords…


LayOut Technical Issues category created