Enscape - Reflections in glass that shouldn't be there

Hello, All.
I am getting reflections of the sky on my glass and mirrors when there are no windows or openings in my model.

I am entirely new to Rendering, so maybe I’m just missing some toggle buttons or something else easy.

Can anyone help me with this?

What does the SketchUp model look like in Monochrome style? What settings does the glass material have? Or the mirror material?

The glass is the standard unaltered SketchUp glass.

Monochrome style… or in other words, are there any wrongly oriented faces (blue visible)?


Glass settings in Enscape.

:rofl: Sorry.

Here you go.

With Google search I found this about glass material in Enscape Enscape | Glass Rendering Tips for Realistic Architectural Visualization

Check the settings for glass and mirror and see if they have textures in any of the fields.

1 Like

Can you share the model?

Does it show the same when you press the render button?

Enscape mixes 2 different methods for showing reflections - one is a Screen Space reflection - this is where it takes what is visible to the camera and flips it and maps it to a surface to give the appearance of something reflected- this often works well , but there are often gaps where things can’t be seen.
This is super common in real time rendering.

These will become more obvious if you are using lower quality rendering settings - try increasing it to high or Ultra and see if it continues to do it. I would only expect to see this in the draft/low mode.

As you have an RTX card you also enable all of the RTX nvidia settings in the enscape settings - I don’t see a reason why this should be happening to this extent for you - as you’ve got all of the specialist raytracing hardware.

The Screenspace reflections (SSR) are mixed more expensive methods to fill in the gaps and to show reflected objects correctly,

It looks like you are mostly seeing the former - hence the weird gaps. The Sky looks like the reflection geometry has been culled to remove the walls and you are seeing the atmosphere.

This is more likely to happen if you have lots of nested entities- such as plants with foliage. I can’t see this being the case here.


I use enscape, can you share your model so I can check what’s going on?

1 Like

You were correct that I had my screen rendering setting at Medium. I bumped it up to Ultra, and we are looking much better.

Here is the Rendering that was generated. The other pictures were screen shots and not renderings.

Thanks for your help.

1 Like

Thanks for your help. Everything seems to be working pretty well now.

Here are some renderings of the exterior after getting the settings adjusted.