Glass and Mirror materials not showing up in my model

Hi! I’ve been having this issue that whenever I use any glass material for an object/surface it applies but doesn’t show the material, it just looks empty. I tried opening new files and the same thing keeps happening. For example, the table in this file shows the glass like that.

I can’t say for sure unless you share the skp so we can examine it, but here are some ideas. First, check the opacity of the glass material, if it is 0 it will be completely transparent. Effectively invisible. Second, if you are expecting reflections in the glass, SketchUp’s built in shader doesn’t do ray tracing or reflections. You’d need to go to a real renderer to get that.

The opacity of the material is fine, it only shows the color of the material when I put it to 100. Here it is a skp file if you can take a look at it :slight_smile: (not the same as the one in the picture since it didn’t let me upload it here)
Glass Table.skp (2.8 MB)

I don’t see what is causing your problem.

I see the glass colored a pale blue in your skp, not invisible. I don’t know why you would be seeing something different. Have you perhaps chosen a view face style other than shaded with textures?

You have applied the material to the surrounding group, not to the faces of the glass itself, as you can see in this screenshot. But that shouldn’t matter as the faces inside the group do not have a material. They will inherit the group’s material.

Sounds like this issue.

That does sound similar. Maybe something to do with DirectX12 compatibility? In any case it would be worth looking for the latest driver from AMD and trying installing it (don’t trust Windows to have the latest, regardless of what it says!).

Okay so I tried changing the graphic settings and still was not help. I don’t know if it might be an issue from SketchUp 2024 because I downloaded the 2023 version and I don’t have that problem.

You are showing the Styles panel in the screen shot. What is in the materials panel?

This is what I have:

That table doesn’t match the one you shared.

Did you restart SketchUp after switching to the classic graphics engine?

This is for the other table. And yes, I restarted SketchUp, uninstalled it and installed again.

Clearly there’s an issue related to the graphics drivers. Perhaps rolling back to an earlier version of the drivers would help.

This is the same issue I am having with Radeon Graphic Cards. Seems to be an issue with the driver. I have submitted a bug report to AMD and suggest you do the same. Hopefully they will fix soon. In the interim, switch back to ‘classic graphics engine’ and it should resolve.

How to enable Classic Graphics Engine

  1. Open SketchUp 2024
  2. Navigate to Window > Preferences
  3. Under Graphics > Graphics Engine select: Use classic graphics engine.
  4. Restart SketchUp 2024