Enlarging model in Layout title block frame will not hold, reverts to imported model size

Importing SU 2021 File to Layout 2021. Try to zoom model to fit window, model will zoom to desired size, but reverts to imported view if click Enter or click in Layout page margin… Made scenes of desired enlargement, Layout shows the Scenes 1 and 2, but will not change imported size image to the Scenes. Never had this problem before.

Share your LO file. Don’t click into the viewport to zoom model to fit the desired size on the page.

Please complete your forum profile with SketchUp version and graphics card.

Tried to share LO model, says too big as it is an Add Location constructed topo map. Will cimpoete profile, but have a sufficient graphics card. Is there a new way to adjust the size of the imported SU model in the LO viewport? I do this all the time, so automatic I cannot remember how I do it.
Thank you,

Upload the file to DropBox or WE Transfer and share the link.

Just drag the edges of the viewport. If it’s a 2D view with the scale set, change the scale in the SketchUp Model panel.

As you can guess I am not that tech savvy. This file is a Geo Location terrain, with a rectangle group copied upwards 100 times at 3’ intervals to make a topo map. I normally import the resulting top view into Layout, scale the viewport to my Arch Template, double click the SU view to go to SU, scroll it up to the size I want, position it, and click the margin to exit and it stays set as I set it. This time it does not stay set, and reverts back to the SU screen I imported. I will try to export to drop box, but how do I get the Layout File here? Everything else is working as normal. Been using SU and LO since 2016 version.

Get DropBox to generate a link to the file and paste that link in a reply here.

Downloading file in Dropbox, says will take 2 hours. I live in the Country, slow internet.

While we wait, make a simple SketchUp model file using a cube or something. Create a scene for the view, save the file, and send it to LayOut. Try resizing the viewport by dragging the edges of it. Does that work?

OK, I deleted the entire Layout File, checked the existing Scenes in SketchUp, opened up a fresh Layout File from my home screen, not the SU file, and imported the SU model. Somehow everything now works, including double clicking in LO window to go to SU file, scrolling image for size to fit viewport, then clicking out of window, it set and remained at the full viewport extent I wanted. I have no idea why the previous model was so messed up, but thank you so much for your attention. You SU sages on this forum are always great! . Now I better study Dropbox, it has been a year since I had to upload files for a project. So many programs to remember and keep up with, plus manage country acreage. Anyone want to help saw up and remove the 40’ tree that just crashed on my horse arena fence?

OK. Glad it works. Now. Don’t double click into the viewport to resize the model on the page. There is no reason to do that.

Sorry. I’d love to help you with your tree but I don’t think I’d be much help.

To clarify, the size of the vewport was not the issue. Scrolling the size of the image in the viewport larger (or smaller) and getting it to remain as desired was the problem.

I understood that but there should be no reason to double click into the viewport to zoom the model. Get that DropBox thing sorted out so you can share your LO file.

What is the better way to resize an image, not a scaled drawing, in the viewport in Layout? I have been doing it that way for years, including multiple images in a viewport to get them all arranged as I want.

Drag the edges of the viewport. The model will resize to go along with it. It’s always worked this way.

What you are doing modifies the Camera properties for the viewport so they are no longer linked to the scene in the SketchUp model. This creates issues when you need to go back to the SketchUp model to make edits to the scene. It also creates problems when you have dimensions and labels attached to the viewport.



Thanks. I understand what you are saying, and tried this. The image would definitely enlarge, but how do you see the title block margins behind the larger image? I tried sending the image to the rear, but it just goes to the rear of other notations, etc, not to the rear of the title block , which is locked to Every Page. Also I would have no way of getting a white margin around my map image within the title block. I am usually enlarging or adjusting the angle of a model or a Geo-location map with this double click and scroll-zoom method. Scenes, I usually have the way I want them, and just import and size with the viewport as you suggested. . I referenced scenes in my help request because I had given up on enlarging the size of the Sketchup model by double slicking to open in SU, scrolling it larger within the viewport as placed on the title block. . .

I expect you just need to turn off the background. Most likely you need to set the scene up so the model more closely fills the model space, too.

The arrange commands, Send to back, Bring to front, etc. only work on entities on the same layer. They do not work across layers.

Again, turning off the background in the viewport’s Styles setting would fix this.

For the third time, share the LayOut file. I’ll help you get this sorted out. Without the file all I can do is guess at what you’re doing and that’s a waste of your time and mine.

Thank you Dave, The file is 46MB, and I do not know how to compress that, so have not sent it. The new problem disappeared, and I believe something corrupted the Layout file I was working on, as starting over with a new Layout file worked fine. Your advice to not use the double click to enlarge or alter Scenes is good, had not thought how that would affect a Scene. I am good for now, as what I was trying to do, and got done after starting over with a new Layout file, was use one constructed Terrain topo map full size and also enlarged to show a smaller part in detail.

1 Like

I’m having a similar issue. Every time I make a change in the associated SU model, 6 of my viewports in LO seem to revert back to the SU scene size. The top two which I did at least a month ago seem to stay in place as do 2 other pages of viewports with perspective scenes. I haven’t played with scale, I drag the corners and then select preserve scale to edit the edges to clip the scene to hide the section cuts.

Can you share the LO file?

I’m looking at your file but I see it has contact info. You might want to dete the link so trolls can’t collect it.

1 Like