Zoom Extents command in Layout, question?


#1

Could anyone comment on this, please?

In previous versions of Layout Pro (with Sketchup Pro), you could insert a model into a Layout page, manipulate etc. And then if the model image was too large to fit within the Layout page, you could (on Mac) control key click the image, & you had some command choices. One command choice was “zoom extents”, which if selected re-sized the Sketchup model image to fit within the page space.

In Layout 2017 that ability is gone. Is it available another way? Or is the only way now to use the control key, then “scale” approach & find a scale that works to fill the page with the Sketchup image?

Thanks,
Mike Wilson


#2

No it’s not. Zoom Extents shows up if you right click when have the viewport opened to move make camera adjustments. That’s the way it’s always been.

You shouldn’t be making those adjustments in LO, though. Best practice is to set up scenes in SketchUp for the views you want in the LayOut document. Do not open the viewports in LO to make adjustments because that disconnects the viewports from the scenes. Any scene-specific changes you might make in the SketchUp file will not be displayed in viewports that have been modified. You can tell if the scene has been modified–it’ll be labeled as modified in the Scenes list in the SketchUp inspector window.

If you want to change the size of the viewport on the page, you can drag the edges or corners of the viewport. If Preserve Scale on Resize is not ticked, the model will resize with the viewport. If the scene is set to Parallel Projection, you’ll be able to select a scale from the SketchUp Model inspector window. If you decide you want to change the position of the camera after placing the viewport in LO, go back to the SU file and make the adjustment in the scene. Update the scene and save. Then update the reference in LO. If you open the SU model from the Context menu in LO, the reference will update automatically after you save the changes in the SU file.


#3

Thanks, Dave.

But I still think there’s been a change of some kind. I draw 2d & 3d construction details in Sketchup Pro 2017. Might be a piece of a building, might be a whole building. I insert the Sketchup figure into a Layout page. When I first drop it in, the whole image fits within the “viewport”. However, an example is I may make a Layout doc with multiple pages, & I may drop the same Sketchup model into the different pages. If I double click the model in a Layout page, then move it around changing the camera angle, it is common for the image which initially fit within the Layout page viewport, to now not fit within the viewport and to overlap outside its boundaries.

Before, in previous versions of Layout, ignoring “scale”, I’ve been to control click the model in the Layout viewport, choose “zoom extents”, and the image would fit back within the viewport’s boundaries. That command choice now appears to be gone.

I can accomplish getting the model image back within the Layout viewport’s boundaries by selecting the model, control click, going to scale, & then picking a scale that brings the model back within the boundaries. However, this is not nearly as slick as the old “zoom extents” command that I can’t find anymore, inside Layout.

I use a Mac, SP-2017, a single button Mac mouse most of the time, & a multi-button Mac most some of the time. To get “right click”, I use control-click. This worked for years in earlier versions of Layout to get the “zoom extents”, “pan”, & a couple other commands for the image within the viewport. Double-clicking the model within the Layout viewport still goes straight to camera angle & allows spinning the image. But backing up out of that, & then single control-click the model in the viewport no longer gives me “zoom extents” as an option.

I’ll continue to play around with it & search.

I’m a simple engineer. I don’t do “scenes”, etc in Sketchup. I draw construction details. I may drop the same Sketchup model into Layout multiple times, then change camera angles etc to show different views of the same thing/model. Having to create multiple Sketchup files of the same model, and manipulate each identical model to the desired camera angle, then drop all of them into Layout, so that by default they fit within the viewports boundaries, would be very cumbersome.

I appreciate all advice. If you think of something I’m missing please let me know.

Thanks,
Mike Wilson


#4

And that screws up the connection between the scenes in your SketchUp file and the viewports.

Zoom Extents has always been available in the Context menu after you double click on the viewport.

I do think you’re missing something. You’re using a work flow that means you’re working too hard.

I make construction plans using LO with multiple viewports on a sheet–sometimes a dozen or more and multiple pages. I never have any reason to modify the scenes in the viewports. Even if I use the same scene for more than one viewport, I never open the viewport to move the camera.

Make camera position changes in SU, not LO. Make new scenes if needed but don’t let scenes become modified in LayOut.

Here’s an example of a project I did recently. I turned off the text and dimension layers to make it look less cluttered in this small image.


Each viewport is tied to a scene in the SKP file and not one of them is modified. The inset at the top left uses the same scene as the exploded view below it.To make it I copied the explode view viewport and made the copy larger by dragging out the edges a bit. Then I ticked the box for Preserve Scale on Resize and dragged the edges of the viewport in to isolate the detail. I used an ellipse as a clipping mask to further isolate the detail. There’s no need to double click on the viewport and change the camera by zooming in or anything.

The same sort of thing was done for the detail of the drawer back on the right side. It’s made from the same scene as the view of all the drawer backs.


#5

Dave,Thanks for all advice. However, I think I’ve just figure it out.

In previous LO versions (right after SK became SK Pro, with LO), with a single button mouse, I could double click a SU model in LO viewport, then control-click the model, & I got the small window with choices “camera tools”, “zoom extents”, “perspective”, “standard views”, etc. Now, in LO 2017, with a single button mouse or multi-button mouse, that doesn’t work. I’ve tried it over & over.

But if I switch from laptop screen with single-button mouse connected to laptop, & connect large 27" monitor with its multi-button mouse connected to monitor, & then in system pref’s, turn on the right-click button to “secondary button”, then: I can double-click the SU model in LO viewport, then right-click the model, & then get the “camera tools, zoom extents…” etc options.

I have never used “scenes” before & will spend some time in future learning about that. However, right now its much faster to use what I know: Double-click the model in LO viewport, right-click, zoom in if I’m focused on small part of the model & don’t care about overlapping outside the viewport, etc. Or “zoom extents” if my spinning the model around caused it to get outside the LO viewport boundaries. That’s much easier & what I’m used to, for now.

Thanks for all your advice. I’ve found the change is somewhere in LO, & is regards which mouse I’m using & what Mac system prefs I’ve set for multi-button mouse. Right now, that’s faster using what I know, although I’ll learn about “scenes” in future. I’ve never used them before.

Thanks, Mike


#6

Hmmm… It works for me on both Mac and PC with double left click on the viewport and then right click to get the Context menu with Zoom Extents.

Here’s a screen shot for LO 2017 on my Mac.

You wouldn’t need it with the work flow I described.

You may find your work flow is easier on the front end. If you need to make changes to your model later, you will be fighting that work flow and it’ll take more time than you save on the front.


#7

Thanks. I’ll have to learn about “scenes” & develop that skill.

Our discussion forced me to adjust a long term preference to use single button mouse, to experiment with multi-button mouse & change settings from left & right buttons set to “primary” to right button set to “secondary”. I’ve never been a left-click, right-click, worker. I’ve always been click, or control-click if need contextual commands, approach.

In the past 15 minutes I’ve created a 10-page 11x17 LO doc, dropped my 21 story office building model into each page, & created the SE, East, NE, North, NW, West, SW, SSW, South, & SSE, views I wanted. With the adjustments in mouse settings I just learned, I was able to do what I know: double-click in LO, spin the model in the different viewports to the corner views I wanted, which caused them to overlap outside the viewport boundaries, then right-click & “zoom extents” which brought the corner views (SE, NE, NW, SW, SSW, SSE) back within boundaries. 15 minutes.

Looks like you do pretty sophisticated SU/LO work. I’ll learn “scenes” workflow in near future. Right now trying to get a report out by days end.

Thanks,
Mike


#8

Since I work on both Mac and PC, I use a common everyday Logitech wireless mouse on each computer. The right click is easy.

Good luck with your project. If you want more help getting to grips with scenes and working in LO. Let me know. I’ll be happy to help.


#9

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.