Zoom extents

I’m not sure whether his is a SketchUp or Layout query, but I’ve seen youtube tutorials where Zoom Extents works. For me it doesn’t.
I open my model in sketchup, turn on all layers and enter FitAll, and that’s fine. Take that model into a sheet file in Layout and i click Zoom to Page, fine. but Zoom Extents - everything disappears and i’m at 7% magnification .
I’ll post a model and sheet later if necessary, but before i do that, is there a simple solution i can do, or an extension that will fix this problem which now appears in several of my projects (i do tend to start a new project by cannibalising an old one rather than starting from a new template…)

Zoom Extents in LayOut is a paper space thing. If you’ve got content outside of the paper space it will be included in the view so it’s different from Zoom to Page. Example:

Zoom to Page

Zoom Extents:

Here is Zoom Extents again after I added a red square out away from the paper.

If you are getting some similar view, look for some entity out away from the paper and delete it.

FWIW, Zoom Extents in LayOut has nothing to do with changing the SketchUp viewport.

Hi Dave, yes, I get how its supposed to work, but for me, Zoom Page works as it does for you. Zoom extents should work as it does for you, but instead of it zooming out to include things that are off the edge of the sheet, it zooms all the way out to 7% magnification and shows me a plain red screen. i.e. its zoomed out so far you can’t even see the sheet any more. There are no visible entities anywhere on the screen that could have prompted this.
and that’s why i mentioned sketchup… i thought maybe that there were some invisible entities in the sketchup model that were forcing this to happen…

red screen?? don’t know why i typed red screen… it shows me a plain grey screen …!

420_2020_A1 Elevs extg.layout (13.1 MB)

i don’t know whether this is any help, or if i need to upload the model file too?

No need for the SketchUp file it is embedded inside the Layout file. There is an odd set of very faint grey lines in your Layout file very very far from the page, it’s not in the SketchUp model. In Layout, zoom extents to the “grey” screen, then select all. You will see a rotation handle in the center of the screen, rotate that a bit and your selected lines will come into view. The easiest way to fix is to zoom to your page, draw a selection box around everything on the page you want to keep and cut it to the clipboard, then select all and delete, then choose paste to restore the things you want.

great!
Thankyou, O Learned One

2 Likes

Looks like EF got you sorted while I was teaching. Good deal. It was basically what I suggested with content far from the page. It might be worth checking your template before you start another project to make sure it’s not part of that template. If it is, you’ll have the same experience again.

1 Like

yep, i assumed it was a distant entity, either in LO or SU, but it was the rotate part that i hadn’t tried and that solved it for me.
all good now i think!
thanks everyone

2 Likes