Editing Layout windows


#1

Hi, I am using layout of the first time. I have imported a sketch model and have duplicate windows with different views. I wish to have one of those views to show changes made from the sketch model (basically a garden with plants, then the garden without plants, done using SU layers), however when i update in LO, the changes are made, but they are made to all the models, even on different pages. I have tried ‘locking’ a window, it works, however there is an image of a padlock.

Any suggestions gratefully received


#2

It sounds like you forgot to update the scenes within SU before exporting to LO. Go back and make sure each of the scenes is as you expect.

One thing to avoid at all costs is trying to make any changes to the windows in LO, ie. do NOT double click to open them. When you do that, you break the link to the SU drawing and no updating in SU will be made in LO.

Also, did you notice this text at all:

08


#3

Thank you for your fast response Simon. I did update, and changes were made, the problem I face is that I only want one window in LO changing, not all of them. is that possible?


#4

Yes but did you notice this text this time?

08

Sorry to keep banging on but it is SO much easier to help when one can see the problem in the flesh. Upload the LO file if you can. If it’s sensitive, PM me or do another mock up that exhibits the same issues and upload that.


#5

It sounds to me as if you haven’t made scenes in SketchUp before going to LayOut. I expect you’ve simply copied the viewport through the pages of your LO project and then modified each one to change the view. If that’s what you did, it’s the wrong way to use LayOut with SketchUp.

Make scenes in SU for each viewport you’ll want in LO. Then assign viewports to those scenes. Do not modifiy the viewports to change the view. If you need to change the camera position or zoom, do it in SketchUp, update the scene and save the changes. Then in LayOut, update the reference.


#6

Here’s an example for you.

The scenes were set up in SU, one perspective, the others parallel projection. I imported the first scene, then copied it three more times, then changed the scene I wanted to see. Et voila!

Cheese.layout (209.3 KB)


#7

That’s what I tried to explain in post 2.

Is there ever a reason to modify a viewport in LO? I wonder why the facility exists at all. Unless there is a good reason for it, it would be better not to have it, or at least for there to be a health warning as soon as you double click inside a viewport.

I’m not entirely convinced that your assumption does describe what the OP has done but without seeing the file it is (as usual) hard to say.


#8

I can see using that for a quick and dirty one-off document but for most projects it is not a good way to work. I’ve never had any need to adjust the view in LayOut and don’t even do it for the quick projects because the correct workflow is ingrained

I agree. A feature request has been made to add a switch to disable modifying viewports so they remain attached to their scenes in SU.

Exactly!


#9

Sorry gents, i ignored the initial request to upload as i thought it was a mistake, (it has something to do with a dark room written on it), anyway i have tried to upload but file is too big, i have reduced it down to just one page with only two images, but still too big…?


#10

Upload it to DropBox and share the link with us.


#11

https://www.dropbox.com/preview/Layout%20117%20test.layout?role=personal

Hope this works. image on top is the garden, the smaller one is a plan view, I wanted this without the plants


#12

You need to change the file from personal. We can’t get to it.


#13

#14

Downloading now.


#15

OK. So you do have scenes although You aren’t using them correctly. Both of the viewports started from the same Scene 1 but you’ve modified both of them to create the views.

If you want a plan view without the plants, make a plan view scene with the plant layer(s) turned off. Do not modifiy it in LayOut. You can adjust the size of the viewport on the page in LayOut but there’s no reason to make it show as modified in the scenes list.


#16

Okay great, thank you, I thought I needed to piggy back each new viewport from original window. So, how do i get a new viewport? when i try a new scene it just tries to create a new file/worksheet


#17

Copy the first viewport in LO. Select it and hold Option while moving it to create a copy on the same page. Then in the SketchUp Model inspector window in the tray in LO, select the other scene.

I also notice you aren’t using Layers correctly. That’s something you want to fix. Keep all edges and faces on Layer 0.


#18

Thanks Dave, that is how i copied them originally, however I don’t understand the second comment regarding SU model inspector, is that in SU or LO?

thanks for advice on layers, do u mean SU? As for LO I’m totally new and not understanding layers there too well so far.


#19

That’s in LO. There’s a tray normally found on the right side of the screen in LO that has a bunch of inspector windows. One of them is SketchUp Model. If you don’t see it, or the tray, go to the Window menu and enable it because you need to access it. You select the scene from SketchUp in that window.

Here I’ve edited your SketchUp file and create two new scenes. One to replace the top one, the other to replace the plan view.

Yes. In SketchUp all edges and faces should remain on Layer 0. Only groups and components get assigned to other layers. the geometry inside should remain on Layer 0 and Layer 0 should remain active at all times.


#20

ah brilliant thanks for your advice, so is that why i get hidden geometry issues at times? so, never draw on another layer, but draw on layer0, group it with other groups/components, THEN put it on the different layer so i can turn on/off accordingly, right? checking the LO advice now. thanks once again