Dynamic Components assigned Options (X axes width) wont Show?

Hello my first time attempting to work with Dynamic Components and YEP!! STUCK!! I am following along with a SU You Tube video: Creating Dynamic Componets-1.
A simple box and I have assigned its Position and in an attempt to allow four different widths for the X axes.( At around the 4:25 mark) I have the details icon on its line and have gone back and hit apply 3 times now. From the screen shots you can see the component (box) is selected but the Component Option drop down says to select component to view options?? I even have Outliner showing that it is selected. But unlike in the video there is no list with the four width options to select.
I have got back and repeated the steps but I AM NOT CATCHING SOMETHING. I put nothing passed myself as far as mistakes or errors. Any help will be appreciated, it tells me to select a component. But it is!! Dont know if you need a file, it is a lone box!! but here are the info from on screen:

I assume that you hit apply…

I Use windows7, 64bit and latest SU.and have this trouble occasionally in that the option dialog does not update,
I turn sketchup off then turn it back on again. In the great traditional windows fix.This can fix it, if not I turn the computer on and off… then no problems.

There probably a graphic card issue or something, but beyond my abilities to work out

I’ve had same problem (Component Option box says No Components Selected even with component selected) & done same thing to fix it (close & re-start SketchUp). This is extremely annoying & now that I see I’m not alone I’m hoping its a fixable bug: hopefully someone from the SketchUp team will see this & reply.

I’m running Windows 7 with 64 bit version, IE 11 update version 11.0.17, & SU 2015.

1 Like

Just did that, saved model and closed SU. Opened a new instance and retrieved saved file copy and as you
can see from screen shot it did add Dynamic in the Outliner. In the first pic it has Untitled so it did update?? I also have Windows 7 Pro x64bit. And IE 11 and just got complete Windows // Microsoft updates 4 days ago. I named the file that when I saved it. I have hit apply 5 times now as far as the different size options are concerned for X axes, and if I did not they would just clear out and would not be listed. If I de-select the box (component) my Attribute box clears of the lists and to re-select all the info is viable…it is the options box that is screwy?? Never having used them I am really stumped. I am no genus but from the pic`s I have the component selected in order to get the info in the Attributes box and the Options one still says “Select a component to view it…” WTF??? Any clue??

can you post the file, then can see if can get a different outcome,
basically to confirm the bug

Just did the complete shut down and it is now visible… so at least I know what to do and it does not relieve the SUCK factor any!! I seen your request just popped up pcmoor.

pcmoor this is the screen shot after a complete shut down of computer and restart… closing SU only updated the file name in the OUTLINER as the previous posts show. Also any size I choose from the options re-sizes the X axes when I hit apply. Getting it to view was my issue with out ANY FORM of shut down.

I am going to try a complete new file and repeat everything exactly and see if it repeats itself, as far as not listing any info in the Options Box even with the component selected. I will be back!!!


Hey pcmoor just had to do a complete shut down in order for it to produce info in the Options box. Closing SU and saving file, then re-opening it does nothing. I can share either file or both. I had to, just as jorenste
had stated he also had to SHUT DOWN THE SYSTEM in order to continue. I, like him have Win7 Pro x64bit and SU 2015 Pro. I do not think it was intended to work this way?? Any advice or how to pass this forward to the R/D department??

DYNAMIC.skp (58.6 KB)
Dynamic2.skp (32.3 KB)

start a new thread in technical problems…with possible bug will get the teams attention

Cool I will…also just added some wood grain to the key hole file. The Options came right up. Created another new file and I did not have to re-start it for the Options to show?? I will be crashing out and first chance I get tomorrow, try it again. Just that three out of four tries failed says something is up. Will see what happens after some down time… Thanks for your input and time, not having any experience with them. Plus doing baby steps following the video I was very frustrating for lack of better words!! …Peace…


Thanks for the suggestion about starting a new thread in technical problems; I will do so for my OPTIONINDEX problem. Hopefully I can just reference the existing post to avoid double-posting.

Hey Chief I stuck it in Technical Problems this morning, I just got in from work. I made three more new files last night, and only the last one did I not have to do a system re-start. I made a new file just before posting this and had to re-start it for the Options box to show anything…IT REALLY SUCKS. I dont have clients yet but I bought the commercial version to make money with and faulty equipment is not good when starting out!!

Was asked to share this here as I am not the only one with the issue. I can assign different length attributes and with component selected the Component Options drop down remains blank. saying to select a component to view options. It is selected or I would not be able to view anything in the Attributes drop down. Closing SU did nothing only after a complete system restart did the Options become visible. I have Windows 7 Pro x64bit and SU 2015 Pro w/ IE 11 and Fire Fox as Silver-lite 5 sucks. I installed Window//Microsoft’s lasted update package 4 days ago. The link to the right is the complete original thread content
…Peace…

UPDATE TO THE THREAD
mrwmrutski
1d

Hello to you and hope you don’t mind the question. You do list bug catcher as a badge though. I posted this issue in Dynamic Components and had two other users comment/encounter the same issues. It was mentioned to move it to Technical Issue as that area may get it better attention. No one has offered any input or explanation as to what could be wrong.
We have Windows 7 Pro x64bit and SU 2015 Pro…working with Dynamic Components we have no trouble selecting the component and going to Components Attributes from Window. If the component is selected the Attributes box is opened with all the listed categories and selections. Say it was a kitchen cabinet or a window with five different lengths and widths per style. The only way to get the list in the Components Options to appear is to save the file. Then do a system shut down in order for SU to update it and show the list. While the component IS SELECTED it is still telling you, that you must select a component to view its options as the drop down is empty except for this instruction??? I tried to just save the file and close and re-open SU, as you have to some time with the older way of installing extensions. Only a complete system shut down will make the options list appear in the Components Option box with the component selected.
I am new to this but this cant be right, or is this just the way it is and a Windows issue??? I took the time and made 4 different files of a single component and added attributes for the width. I had to do a system shut down for the first three to get the Components Options list. The fourth one gave me the options list without a shut down??? I crashed and made a new component file in the morning after 6 hours and it made me shut the system down to get Components Options to list while the component itself is highlighted the whole time… I can share the screen shots showing this or make a new single component file to share. ( The originals are posted in the forums ) It just makes no sense to have to do this and very curios as to why, I am weird that way. Even as a kid if something was broken and thrown to the curb I was taking it apart to see what was going on even having no clue how a TV worked at 8 years old!! If you have any words of wisdom or can shed a bit of light on it would be great. At least I can go back to the other two users and share something as it is bugging them to. Thanks for your ear and time…Peace…

Hey folks,
I’m encountering exactly the same problem like all of you did - only in 2016, so maybe there’s help!? :slight_smile:
I’ve just finished building a dynamic component and wanted the user to have the ability to manipulate the attributes of it. Unfortunately, while working fine for a few days, now the Component Options window remains empty when clicking on the dynamic component. I double checked by starting with a new File and still get no Options for the new component… The Display rule is set to "Users can edit as a textbox."
What am I doing wrong?
Help is highly appreciated - thank you very much in advance!
Joe

–EDIT:
ThinkPad T450s
Intel HD Graphics 5500
Windows 10 64bit
SketchUp Pro 16.1.1449 64-bit

I was just experiencing the exact same problem. Then SketchUp crashed and now I can view component options again.

Hey Mike,
thanks for the quick reply! My error remains for several days now, in the meantime i restartet both computer and SketchUp multiple times… Any more suggestions? :sweat:

I’m not sure. As I recall I wasn’t able to use the component options since last week. Also right now I only have one file open and it is pretty small, about 300 KB. I am opening up a larger file now out of curiosity. I have a feeling its not going to work properly. Should we start a new thread under technical problems?

Is that what you’re getting?

exactly!

–EDIT:
Sorry, didn’t see the other message above!
I’m new to the forums, so I’m not quite sure how the structure works, but please feel free to involve me into the new thread/topic :innocent:

–EDIT2:
Here’s what I’m getting (object and attrbiute names are in german, though…):