Drastic slowdown with SketchupPro 2019

I have experienced a dramatic slowing of Sketchup in switching from 2018 to 2019Pro. It takes 50+ sec to save the *.skp file. It used to take maybe 5sec. On the new laptop at work, it takes 3sec. The model has 258k Edges and 125k Faces. The home computer is Dell Inspiron 3650 CPU=Intel i5-6400 2.7GHz; Win7; 64bit. I did several upgrades, with no effect: 8 to 16GB RAM; Add SSD; Add NVidia GTE1050Ti; OpenGL with Fast Feedback; Win7 to Win10; uninstall all extensions; unplug internet; turn off Anti-Virus; Copy *.skp from Dropbox to local; SketchupCheckup = Fine. None of these made any difference. I am more than a little frustrated. Help!!

PS: Task Manager shows CPU at 25% and “not responding” for most of the time.
Also, I did SaveAs …2017 version, then run with 2017_Make. This saves in 3 sec. Open that file from 2019, saves in 30 sec.

1 Like

I forgot to say that the Task Manager shows CPU at 25% (and Sketchup “not responding”) for most of the 50 sec.

When did you install 2019?
Did you install it by rightclicking on the downloaded installer file and choose ‘run as administrator’?

Thank you. I removed then re-installed, as admin. No change. Meanwhile, I tried del old versions (2018 and 2017): No change. I also tried SaveAs 2017, then open/save w/ SketchupMake_2017: Now 3 sec save!? Open that 2017 version in 2019 - back to slow save.

1 Like

I have noticed the same thing. Everything seems to be going fine and then it just bogs down. Updating an attribute of a DC 50+ sec in 2019 100%CPU usage, same file saved as 2018 and opened in 2018 takes 0.5sec to update. I have been chasing this for a while and was unsure if it was a DC problem I somehow created, reading this post prompted me to try the 2018 route. No doubt in my mind that it is a 2019 issue.


• “Window > Model Information > Statistics > Purge Unused”
• add: show everything (unhide objects / switch on all layers), select all and copy & paste to a new document
• Extension Warehouse: CleanUp³
• SketchUp Help Center: Improving Performance

Hey thanks for the response. I clean and purged regularly and it has no effect on this issue. Why does it work so well in 2018 and so badly in 2019? the exact same file…

PROBLEM FILE TEST2019.skp (14.7 MB)PROBLEM FILE TEST2018.skp (14.7 MB)

Hey Sketchup Team, a little help here? Why does it run better on an older version?

Trade-off for all the new features?:wink:



Thank you for taking up the gauntlet here. Part of the my puzzle is that it runs fine on a newer laptop – clearly the old CPU is slower, but not 20x!


1 Like

I’m not seeing any performance issues with your 2019 model in 2019. Navigation, editing, etc, all seem to work smoothly for me. Looks a little jerky in the GIF but that’s the low frame rate.

Try changing the value of one of the dc attributes. All I did here was add the 2 to a label, no formula even. I cut the middle of this screen capture out, total hang time was 70 sec. in skp 2018 the same file on the same machine updates in a blink.

Real time. No cutting out the middle or any video trickery.

Some plugin, perhaps? Do you have Outliner open? Or the components window? Typically, changing DC attributes results in an addition of a new component definition with its own thumbnail etc.

so it’s something to do with my setup then? Obviously it has something to do with 2019 and my system, because it works like yours on 2018.

Hey thanks for the response, I have been using these components and they have worked fine in much more complex models with 2018. Since switching to 2019 I have noticed it being slow, sometimes unworkable. I thought perhaps it was the way I was using DCs and spent many hours trying to find a problem there, I still haven’t. Today I tried opening the same file on both versions of Sketchup on my machine and it only gets stuck in 2019, the exact same file. So what has changed? I copied everything to a new file and it improved the hang time in 2019 to about 20 sec. If I place a single component in a file it performs fine. Regardless, why does it work so well in 2018, and not in 2019?

Hey NP. It was the switching versions to an older one you did. That got me to try the same thing and realize its not my DCs. Wasted a lot of time there, thanks!

is it plugged in and running on the Radeon card?

power saving often flips to the Intel card…

both cards are small for a model with such big textures…

try this version where I reduced 3MB of textures and unused materials…

I also moved it to origin as that was affecting my iMac [8GB nvidia]…

lighter.skp (11.7 MB)


1 Like

I think it is. As John suggested, it could be the graphics card. Also as he suggested, neither of them are especially good for 3D modeling. The graphics card in this computer is an old, not particularly excellent one by today’s standards but it is an Nvidia GPU. Nvidia has always had a good track record when it comes to OpenGL support. Intel and Radeon not so much.

He brings up another good point. Why is your model over 290 feet from the origin?

1 Like

Hey and thanks for the help. Model is out in space because I pasted in place from the original file, moved that part to a new file to reduce the size for upload and to see if it would speed things up any. It did a bit. I just don’t understand why it works as intended with no lag at all when I use sketchup 2018 (same machine and setup with 0 problems) and not in sketchup 2019. Are we saying that to run 2019 effectively I need to get a new computer? This one got me through architectural school fine. Sketchup 2017 & 2018, autocad and revit. Still runs autocad and sketchup 2018 fine (I dropped revit), but not sketchup 2019? I just don’t get it. Navigating the model and modifying the geometry using 2019 is fine on my machine, it all works except updating the DCs attributes, where it just hangs there. I think I am just going to go back to 2018 for now and hope this gets fixed in future updates. It is not just this file either it is an ongoing problem that I didn’t have before 2019…