Don't want to see the rest of the model through the windows/doors

This has got to be a function that all architects use on a daily basis so I’m pretty sure I am missing something fundamental here. I am working on a 3D model of a house (basic all black and white, no texture, nothing fancy). When I look at the standard Front View, I can see elements of the back wall through the front doors/windows. I don’t want to see the back wall??? Do I have to put actual windows and doors so you don’t see the back wall?

Set the Face Style to Monochrome, Becca. I’m assuming you have windows and doors in the openings which have a transparent material applied to them.

Please don’t take offense, but this seems like a silly question. If you cut a window opening in a wall but put nothing into it, wouldn’t you expect to see through that hole? You have to put something opaque there or of course you will see the “nothing” that is in the opening.

Thank you for your response. I just have holes for windows/doors so I know why you can see through them! I just thought there might be a way not to display what is showing through behind them without putting in windows/doors.

1 Like

Two options:

  1. Fill in the openings.
  2. Draw a large rectangle just inside the wall to act as a curtain to obscure the background. Group that rectangle and put it on a layer so you can turn it off when you don’t want to see it.
1 Like

Thanks Dave. I appreciate you!

1 Like

Thank you!

FWIW, here’s an example of the second thing.

A rectangle drawn just inside the front wall of the house for the lower floor.

And the front view. Note you can see in through the upper windows because I didn’t add a face there.

1 Like

I’m sorry but why on earth would you not put a face representing your glazing in your windows? Once you do you can apply a glass material to it. I simply change the opacity when I don’t want to see through them.

1 Like

I can understand why you might want to do something like this. In the very early stages of design you might cut openings in walls but not yet want to spend time populating them with windows. So you have a hole with nothing in them and inevitably then see whatever goes on in the background.

Funnily enough, this very subject came up in another recent post with another workaround involving an extension: Depth of section cut

I’ve done basically what @DaveR has suggested before. This model is just an exterior shell with no interior. There’s a black out box inset for the whole shell shape. I didn’t have Joint Push/Pull at the time, but it would have made it quick and easy. It’s on a layer called “interior black-out” so it can be turned on and off at will

1 Like

Also try playing with the Fog settings to obscure things in your scene. https://help.sketchup.com/en/sketchup/letting-fog-roll-your-model