Difficulty opening viewports / scenes / pan tool

I have been having problems opening viewports in layout. I used the LO insert command to insert my model into my plan. For some reason unknown to me, I have to pass the cursor over the edge of where the view port might be for it to turn on. When I have an image in a viewport, if I pass the cursor over it, and click, it opens up. But not the imported model. It only opens when I pass the cursor over the edge.
I have also tried sending the model to LO from SU, but there’s no improvement. Nor does updating the model reference in LO.

How do I fix this, or am I doing something wrong?

next. I saved scenes in my model. I exported my model to layout. I right click to open up the viewport menu - I click on scenes - they are not there. Just the last scene when I saved. Not knowing how to fix it, I did screen shots of the scenes in SU and imported them as images. How do I get the scenes to be available in LO?

The pan tool has disappeared from LO. With all these problems, I am wondering if I should delete and reinstall LO.



The main thing not to do with Viewports in Layout is to ‘Open’ them. This implies to me that you have maybe double clicked the viewport?

Doing this means the Scene Selection in the Sketchup Model tray, in Layout, will show as ‘Modified’. If this is the case, then the link to the Sketchup Model is broken. Any changes to the Sketchup Model will not be shown in Layout.

Not sure why the Pan Tool has disappeared. I understand that when installing Sketchup on a Windows machine, it’s a case of Right Clicking on the Install File and selecting Run as Administrator. This can cause problems, if not installed in this way.


1 Like

I did not double click on the viewport. I imported the model by using the insert command under File. The model appears in the LO screen in the viewport called floor plan. All of the others, framing plan, demo plan, foundation plan are images I made with print screen, then pasted them in the plan.

When you click on it sometimes it opens, sometimes it doesn’t. Then I have to hover over where the bounding box border should be. Also to get the large popup ( which has some 27 items listed) I have to be hovering over the blue bounding box border, or else I get a small popup ( paste, paste to current etc.) And BTW, the scenes button on the popup doesn’t list the scenes.

Here’s the file - check it out. G

Edit - the pan tool is on my desk top but not my laptop. Weird, huh? I drew this on my laptop at a job site while keeping an eye on my workers.

sample plan.layout (8.7 MB)

The style of the model is set to not show the background, partly to let the graph paper through I suppose, and also so that the labels can be underneath the model or picture. If you turn on background you can then select the model by clicking anywhere over it, or you can right-click anywhere on it to see the full menu.

While background is turned off you have to be pointing at geometry to get the full menu, or to guarantee selecting the model.

Not sure about the pan tool difference.


This file has so much wrong with it that it’s difficult to know where to start.

Not that weird. If you have to have the Pan tool on your toolbar, put there. The Pan tool isn’t displayed by default. Customize the toolbar anyway you want. Or make a new toolbar.

You and I have talked about this in the past. That viewport is tied to the Last saved SketchUp view and not to a scene as it should be. You are inviting trouble by not creating scenes. for the views in LayOut.

Why would you do that? You are using a raster image in place of a scene from the SketchUp model. the raster image are low quality and look awful. If you have reason to go back and edit the SketchUp file, you’ll have to recreate these images and replace them in LayOut. You should create scenes in SketchUp for those views and create viewports in LO for them. They they all come from the same SKP file, create the additional viewports by copying the first. Don’t insert the file again.
Raster images that you do have to import (site photos, for example) should be inserted into LayOut like you inserted the SketchUp file using File>Insert, not paste.

That’s because your SketchUp file has no scenes.

As Colin wrote, since you have the background set to not be displayed, you have to click on some part of the model to select the viewport. This has nothing to do with how you get the SketchUp file into LayOut.

There are no scenes in the SketchUp file attached to the LayOut file you shared. The Scenes panel is empty.
Screenshot - 12_20_2019 , 8_05_35 AM

If you modified the SketchUp file to add scenes and it isn’t linked to the LayOut file. Go to File>Document Setup>References. Find and select the .skp file and click on Relink. Select the saved .skp file that has the scenes.

And as Mike wrote, you shouldn’t be opening viewports at all.

As I started out, the Pan tool is not shown on the toolbar by default. The Default toolbar looks like this:

Customize the toolbar if you have to have the Pan tool on it. Personaly I’ve never found a need for it since it works exactly like the Pan tool in SketchUp using center mouse button with Shift.

Dave - the scenes I created in the SU model would not open when I inserted the model into the LO. I could not get them to open so what was I to do? I had a dead line. Thus I inserted the images from screen shots of the scenes in the model. It got the job done.

I used the insert command to “paste” the images in my document - sorry if my terminology was incorrect.

You say my SU file has no scenes yet they are listed under the tool bar along the top, and in the scene section in the tray. I am confused why they are not available. I saved the model before sending it to LO.

I use the pan tool to move the document back and forth. I prefer it over the sliders on the side and bottom of LO.

Colin - How do I change the background then? I can’t find it listed on the pull down menus.

The SketchUp file in the LayOut file contains absolutely no scenes. Your screenshot shows a different SketchUp than the one used by your LayOut file.

This shows the one in your LayOut file. Not only are there no scenes, the dimensions are different as is the selected face style.

The file name is different, too. That ought to be the biggest clue. The one in the LayOut file is called “floor plan_805” while the one in your screen shot is just called “floor plan”

As I wrote earlier:

I do, too. That’s why I use the center mouse button with Shift to activate Pan in LayOut. It’s the same way as doing it in SketchUp.

If you want the background displayed in the viewport, select the viewport and go to the Styles tab of the SketchUp Model panel. Tick the box for Background.

The problem is possibly I copied the file to a thumb drive from my laptop, and uploaded it from my desk top. So here is the file uploaded from my lap top.

Maybe this will have the scenes that the other doesn’t. I still can’t get the scenes to open in LO. This is a copy of the original - I deleted out the address and identifying information. I didn’t feel comfortable posting that info on line.

I tried copying the floor plan to another location and opening it to see if the scenes would now magically open - no such luck

sample plan.layout (8.7 MB)

I had no idea that pushing on the center mouse wheel turned on the pan tool. Thanks.

It does.

Nope. In this latest file that you’ve uploaded, not one of the views of the model is a viewport. They are screenshots and thus, raster images. If even one of them was a viewport, the SketchUp Model panel would be active. Screenshots have no direct link between the model and the LayOut file so no amount of updating the SketchUp or LayOut files will change anything. You would need to make new screenshots and insert them into the document to replace the old ones.

How about uploading the SKP file you made the screenshots from?

here’s this test file. It consists of the imported model only. The scenes in the SU model are not available in it. I am also uploading the SU file.

floor plan.skp (180.1 KB)

test.layout (151.4 KB)

That SketchUp file does not contain any scenes so it isn’t surprising that there are no scene ttyo select in the LayOut file…

Here I’ve added a scene to the SketchUp file you uploaded.
Screenshot - 12_20_2019 , 10_23_58 AM

I saved the changes to the file and relinked to the saved file in LayOut.
Screenshot - 12_20_2019 , 10_23_35 AM

Now the scene is selectable in the LayOut file.

I am beginning to see my problem -it was opening an earlier version before I created any scenes. Try this.

floor plan.skp (259.1 KB)

So too many files with the same name.

While I was waiting, I redid the dimensions and labels in LO.

OK. This latest file does have scenes. I changed the camera to Parallel Projection for them, saved the changes and inserted onto a new page in your last uploaded LayOut file.

Three separate viewports, one for each scene. You should do the labeling and dimensioning in LayOut. It’ll look better and be more easily controlled.

Sorry - I had to run meet a building inspector, or I would have responded earlier. I still struggle with the text tool in LO - it’s easier for me in SU. Maybe it’s a matter of more practice.

Part of the problem is my method of sequencing. I will open a model in LO, label it. Then as I go along, I realize I have to move the viewport. When I do, none of the labels move. When I move them they get distorted, so I end up erasing them and redoing them. So, if the labels are in the SU model - they move intact as I shift the viewport to a new location.

I forgot that the camera needs to be changed. I don’t do plans often enough to have it down pat.

So, we have the answer to why the scenes weren’t working: it was referencing an older version of the SU model I wasn’t aware existed. I kept trying to send the version with the scenes to layout, but it wasn’t linked to my LO plan, creating havoc.

Mystery solved. Well thank you for persisting. I always appreciate your help, and I hope this thread helps someone else.


Why don’t you select the labels along with the viewport and move them together? Nothing gets distorted that way.

In the SketchUp model, in addition to viewport scenes (for use in LO,) you should create a “Work” or “Edit” scene with fast styles (textures & shadows off, monochrome mode, no profiles, etc.) Then when you need to tweak the model or add geometry you do so in the “Edit” scene and then all the LO scenes will be unaffected and you will not be inadvertently changing their camera positions.

Basically think of the “Edit” scene as the scratchpad. It won’t be used in LO so it’s camera can be left in any position (and in perspective view.) And also it’s style is set for fast modeling, not in any presentation style that will slow things down.

1 Like

I have tried several times with partial luck. I will try again. I notice all your labels are inside the viewport - mine weren’t. Maybe that was the reason. G

My labels were on a separate “text” layer over the viewport. They are not inside the viewport.

wow. I had no idea. ok. Something else to learn. G