Dae import incomplete


we develope our on CAD/CAM.
Our costumers use our collada Export to get 3D-model in Sketchup
In the attached file, Import ends by 75%. I cannot find an error and other Viewers can the Project Import completely.
I hope anyone can help me
collada.zip (1.4 MB)
Best Regards

Importing the .dae into SketchUp 2015 works OK here and takes just a few seconds.
Here’s the .skp

skpA0C8.skp (2.9 MB)

thats rigth,
but in your project are not all components imported, too.
take a look to attached image, please.

The DAE file imports quickly and SketchUp gives no error report.
Here are the import settings I used.

There are other things missing in the collada file too.
I notice the green material in your image. There is no green material in the collada material folders.

the Image is from our costumer. if I export project with my pc I don’t have this texture.
If our costumer exports the texture is allready in material Folders.
My problem is, that I don’t get an error message or error log, too.
I used same options to import in SketchUp.

Do you not have several faces reversed ?
Either in your DAE-exporter processing, or in the original SKP [which we don’t have]
There should be no blue faces seen in Monochrome mode…

1 Like

Thanks, we don’t look for reversed faces.
I try this and give you feedback

I have removed all components with possible reversed faces.
The components still lost after import.
I don’t know what could be wrong with the components

Before unzip unblock it. If that is not doen at that level then all will be blocked and they have to be done one at a time.

Su 2015 Make, windows 7 64 bit components missing; Su 8 Make model ok , some textures not applied to some of them.

I use Windows 8 64 bit, I have changed all textures to one and then exported. same result. My Problem is, that I don’t know which solid make the Problem. I thought a sketchup developer could debug the Import and see the Point, where Import ist aborted. I think the Problem is in model, too. But I don’t know where or what component

The DAE file does contain the missing parts - see the MeshLab screen shot:

The ‘black’ is the reversed-faces !
Blender also shows all of the parts:

So it appears that there is something in the file which causes SketchUp to miss out parts…

Blue faces are reversed

1 Like

Since we don’t have the original SKP it’s hard to say what is different about the missing parts.
If the SKP is purged and fixed under Model Info > Statistics is the DAE any better when imported into a SKP.

Reading the text of the DAE file I see that any tiny exponent-defined floats are written with ‘,’ [from the EU decimal-separator débâcle] whereas decimal floats are otherwise written with a ‘.’
-5.056382E-08 versus -5,056382E-08
However, editing those to be formed with a ‘.’ makes no difference - there are still missing parts - I suspect that the DAE importer already does a ‘tr’ anyway ?
I also note that a material name contains an umlaut ? ‘Lärche3’
I’d not expect that to be an issue, but we have no better ideas so far…
Renaming it has no effect.
All imported materials come in named “N” anyway ???
The ‘1’ uses texture ‘laerche2s.jpg’… so I guess that’s it ?

Exporting as DAE from Blender makes a file that fails to import into a SKP completely !

I took the DAE into an online converter and reexported it as a DAE.

That new DAE imports into a SKP and now has no missing parts.
However the textured materials are made 100% transparent ! [fixable by editing], here it is in MonoChrome - showing the missing parts are back ! …

After applying this in the Ruby Console to make all materials fully opaque:


You get this:

So the DAE is salvageable - even when it has such poorly oriented faces…

1 Like

Using MeshLab to " clean + repair" the op model:
24 degernate faces , 28095 duplicate vertcices , 17195 folded faces => must have a clean model before too many conclusions are drawn?. Final result can be filter application sequence dependent so more work needs to be done :smiling_imp:

Here is one for you.I used Su 8 to to import the dae file and then saved as a skp file. I then opened in su 2015 and it appears the components are there+. you need to checkcolladatest.skp (2.9 MB). Saving as su2015 and then open in it ok :smiling_imp: Steve has been AWOL in all my skp files?

I can confirm this.
I imported the DAE into SketchUp v8.
It gave an error - ‘unable to verify…sure?’ - but it did import OK anyway.
ALL of the missing parts seem to be there.
I also tested it in all newer SketchUp version [v2013 onwards], and there are no messages AND bits are missing.
It seems that newer DAE importer is less forgiving ???
Trimble need to look at the importer to see what’s changed - v8 can cope as can several 3rd party importers, so what is different in >=v2013 ? I have reported it directly to them…
Here’s the v8 result, showing the previously missing elements.

1 Like

If I export from v8 as dae then import it to 2015 works ok , Steve still AWOL and some textures not applied. Shortly after SU 8 release I tested it with the Krono’s group test model of astronaut and moon buggy and was OK but have not done such test since to other versions assuming Trimble knows how to run regression test.

Thank you, to spending so many time to my issue.
If I understand it right, in Version SKP 2013 the Import runs without missing parts and it seems, that Skp 2015 have a difference by importing dae?

[quote=“b_wensauer, post:18, topic:8598, full:true”]
Thank you, to spending so many time to my issue.If I understand it right, in Version SKP 2013 the Import runs without missing parts and it seems, that Skp 2015 have a difference by importing dae?
[/quote] Import of the problem DAE into SketchUp v8 works OK - there is a ‘checking’ warning, but it imports OK.
BUT all newer SketchUp versions miss out parts, without any warnings.

Thank you,
I have tested it. If I set Option check Import, Import is not ok. is there a possibility to get a log file of the error?