Importing dae-file fails

import
bug
dae
collada

#1

I’m using SketchUp Make 2016 and trying to create some models for a friend which involves using some DAE files. I’ve attempted to import two different DAE files and both fail to import. I see the progress window and somewhere around the 5% mark it just fails and reports that it failed and does not give any details.

In the options of the import I also tried turning off the two options, still the import fails.

I was going to attach two DAE files but I don’t understand how to attach the files to my post.

I also have a few MAX files but they are not seen when I try the import and in the dropdown for the file type MAX is not present.


#2

This will allow you to upload a file. Without looking at the file, best we can to is guess.


#3

There is an Upload button lurking in the messaging window.

The application the DAE files have been exported from might have used a nonstandard export method.

As to MAX files, they are proprietary to the 3D Studio Max application and cannot be opened or imported by any other application.

Anssi


#4

Anssi, much thanks for the info!
I also discovered I can drag-n-drop to the forum. Following are the two files I’m trying to import.
DL422N shelf.DAE (2.3 MB)
Ops I was able to upload only one file. I’ll try another append to the thread.


#5

OH Darn the file is too big (3210 MB) and the limit is 3072 MB. How do I get around this?
The file I tried to attach is a zip file thus I don’t think I can compress it anymore.


#6

You can upload the file to the Trimble 3D warehouse (or your favorite file sharing site) and provide a link to it here. Just be sure to make it public accessible.


#7

I can’t open that file on my Mac either by importing in SketchUp or via the default dae viewer. Both say the file is defective. You didn’t zip it and then name it .dae, did you?


#8

Perhaps I have success. The ZIP file I tried also had a DWG file in it. I just used 7zip and it is much smaller.
OH Darn I cannot upload a 7z file.
OH ■■■■ I cannot upload a RAR file either.
Gondola 96H x 22-22-jgt.zip (2.8 MB)
AH, I had to install WinZip and now it works.


#9

slbaumgartner-No I just unzipped it using WinRAR.
The ZIP files I received are too large for me to attach to the forum. How do I get around this?
Ops I did find one original zip file that is small.DL422N shelf.zip (260.4 KB)


#10

I’ve unzipped each of the files you managed to attach here, and I can’t open any of them using any utility on my Mac. I’m thinking, as @Anssi wrote earlier, that these were exported by something that uses dae in a non-standard way.


#11

slbaumgartner much thanks for trying. I’ll contact my source and see what they have to say.


#12

I took a look at the DL422N shelf.dae using a text editor (.dae is just a specific XML variety, so readable as text). I notice that the first data in the file is an array that says it has 50082 elements yet there are actually over 66000 provided! I think the file is seriously defective!

Edit: Oops! I missed a tag while examining the file. What I wrote above is wrong. Continuing to look…


#13

OK I have success but most likely not the shortest path.

  1. I installed Blender (see https://www.blender.org/)

  2. I then imported the DAE file into Blender. Here is another learning curve. When I opened Blender there was a BIG cube in the window and I was unable to delete it. I’ll worry about that later (more learning curve)

  3. I then imported the DAE file. It looks a bit weird but I pressed on.

  4. In Blender I then exported to a new DAE file.

  5. In SketchUp I then imported the new DAE file. Wow it seemed to work

  6. I then deleted the cube that I originally saw in the Blender window and rotated the remaining unit and it looks GOOD.

I think I all good.


#14

I’m glad you found a workaround. On further perusal of the sample file, I found that it passes its triangle data as a single enormous line of text instead of breaking it up one line per triangle. That saves file size (no line feeds), but it’s possible that the line is longer than some dae readers can manage.


#15

Moltres_ColladaMax.DAE (677.0 KB)

I have the same problem with this Dae File in Sketchup 2017

Anybody know what the problem could be?


#16

That DAE file has all of its image files missing, and is defective - it won’t import.
I suspect this is related to your parallel post you have regarding an issue with a 3ds file and image use - the PNG files share the same names !


#17

This is what I see if I Preview your DAE on my Mac. It looks to me as if the geometry is itself ok, but the plain gray appearance is consistent with what @TIG noted about missing images, and SU import complains about missing textures.


#18

Well I used http://www.greentoken.de/onlineconv/ to convert dae to 3ds before I knew that Sketchup could read DAE files directly


#19

3DS - Pokemon X Y - 146 Moltres.zip (1.0 MB)

This is the entire 3d package


#20

My Mac is able to preview that dae complete with textures, but import to SU still fails without saying why.