Cutlist Stopped Working

Running SketchUp 2017 17.3.116 on Mac, High Sierra. Yesterday, CutList worked correctly. But today, when I ask it to run, nothing happens. I don’t get the list of parts or the layout diagrams I typically get nor the message that the list has been written to file. I uninstalled it and reinstalled using the Extension Manager but there was no change. I upgrade the operating system over a week ago and have been able to run CutList since until today. Are there any suggestions to deal with this?

Are yuou referring to the CutList extension authored by Steve R and available in the Extension Warehouse?

Did you make any changes to Safari? It would use Safari to display the various windows it creates.

I don’t know what the issue may be, but I can assure you it is something specific that changed yesterday on your computer. I just rechecked, and I can run CutList correctly on my Mac with SketchUp 2017 Pro 17.3.116, High Sierra 10.13. Have you tried multiple files to verify that this occurs for all and not just one? Have a look at the CutList options settings (on its start dialog) and make sure they still make sense. Try creating a simple model with just a component or two and see what you get.

Edit: also try opening the Ruby Console while you run CutList and see if anything is reported there.

Yes that is the extension and it was downloaded from the warehouse. Didn’t make any changes to Safari that I know of. I update the computer to High Sierra last week and have been able to run CutList since then until yesterday.

Sounds like you might want to look at this thread.

I have tried multiple files and get the same result. I just tried creating a small SU file with two components. Ran CutList and got the same result - that is no cut list, layout or message that it was saved to a file. I open the Ruby Console and it was blank. I have also tried rebooting the computer, but had the same result. I can’t figure out why one day it worked and the next it didn’t, when I have not knowingly changed anything.

Clearly something has changed on your computer. The extension hasn’t changed in years so it’s not that.

I don’t know what changed. Do you think I should reload SU?

I updated SU 2017 in September before I update OSX. I understood that the SU update addressed the issue found during High Sierra beta testing.

You are selecting the parts in the model space before you run the cutlist?

Tried it both ways. I have tried selecting all of the parts and I have gone to a certain scene and selected all of the parts in the scene. Both have worked for me until this problem started.

Rules that one out then.
I can’t quite remember, but I’m pretty sure that if I run the cutlist for a second time, I don’t get a “cutlist written” notification and it doesn’t seem to overwrite the existing one. If I delete the existing one and then run cutlist I then get the notification and a new cutlist file.
I am on Windows so things could be different in your case, just my thoughts…
Nothing wrong with any of the other suggestions of course…

Here’s a bit a new information. I got CutList to run by fooling around with the Board settings under the Layout tab. I had board sizes, 4/4, 5/4,6/4, and 8/4 selected. When I turned on “output nominal thickness” and set the nominal thickness margin to 1 for 1/16" the Cutlist ran. When I turned off output nominal thickness, it won’t run. If I turned off the nominal sizes, ie unchecked the boxes, Cutlist runs.

That’s valuable new info!

Could you upload a sample file and also screenshots of the CutList gui windows so that I can try to reproduce your problem? For some time I’ve been pondering whether to dig into the CutList code, as it has been unsupported since Steve R. unfortunately passed away.

As a technical detail, since you saw nothing in the Ruby Console it seems likely to me that the problem lies in the javascript code that processes the settings from the gui. Javascript is notorious for aborting without any notice when it hits an error!

1 Like

Ok. One other bit of information. I tried various combinations of the nominal board sizes checked and unchecked and output nominal sizes checked and unchecked. CutList would only run if I had a number in the “Nominal Thickness Margin” box. If it was empty, Cutlist did not run.
replyPrinter Stand V1 SKU.skp (833.4 KB)
Screen shot of Cutlist page before running, 51 AM
Result screen shot, 11 AM
52 AM
At this setting Cutlist did not run.

Thanks for the info! The extension is complex and this is my first foray into the code, so it may take me a while to track down what is going on. Please be patient!

Ok. I’m good for now. Going to off line for a few hours. At least I can run it now!

Using your sample, I found a bug in the handling of nominal thickness margin: it fails when the entry in the gui field is blank (easy to fix). Strangely enough, he trapped this situation in the saw kerf size but not in the nominal thickness margin! You must not have had the Ruby Console open when you ran CutList, as this bug produced an exception message there from the Ruby interpreter that led me to the cause.

If you replace the file

~/Library/Application Support/SketchUp 2017/SketchUp/Plugins/sr_cutlist/gui.rb

with the following, it will fix this bug. Please let me know if that fixes your problem.

gui.rb (10.5 KB)

How to I move this over to the file. When I click on the download symbol, a bunch of coding shows up.

Ack! That’s not the expected behavior. They must have tweaked something in the forum so that Ruby source files don’t download any longer? Will this zipped version download correctly?

gui.rb.zip (2.9 KB)

Edit: yes, it downloads ok but with a nonsense name involving a long string of numbers (this is another recent glitch in the forum behavior). Just double click on the zip file in Finder to extract the gui.rb file and then copy it to the folder I gave earlier.