Cutlist for Mac with Sketchup 2023 no longer compatible -- What can I use

Cutlist for Mac OS 13.3 with Sketchup 2023 is no longer compatible. Any ideas on what would be a viable option?
Lee Jones

ok, when you say it is not compatible, is it :

  • because you installed it and it doesn’t work ?
  • because in the compatibility is doesn’t say SU 2023 ?

if it is the second, then install it anyway, it is just an indication that the dev checked that all is ok, then that they told SU, and SU confirmed.
devs have many extensions, some have other jobs, especially on free plugins, they won’t jump on it to update.

chances are, if it worked on SU n, it’ll work on n+1

when you say cutlist, you’re talking about opencutlist ? or that Cutlist ? if it’s the second one, yeah, it’s 10 years old. but opencutlist works fine.
here, Boris, the dev, it talking about a version 5 :

When I click on it in the Sketchup Extension Library. I get a notice stating it is not compatible. I even loaded it and tried to get it to work. It shows it’s installed and I can open the extension but it won’t run.

yes, but witch one ? can you give a link to the extension warehouse ? (like I did above on opencutlist and cutlist) ?

I mean, there are a few choices.

I’m responding to 2 comments:
Ateliernab asked:

  1. Does it show SU 2023? Where do I find the SU and how would I change it?
  2. Which “Cutlist” am I talking about?
    Show your model as a list of dimensioned parts. Produce a la
    195,221 ViewsFree

Cultist 4.1 will work fine in SU2023. It works in all SU desktop versions.

Please complete your forum profile.

okay. yes, this one is old. 9years old

I was typing a long message explaining that sometime, older extensions are not compatible anymore, but dave’s answer made me doubt.

I installed it and… yeah, it launches.
the “compatibility issue” message is normal, old stuff, at your own risk.

(I ran it with some random file I had)

I’m on sketchup (SU) 2023, macos 13,3,1

Anyone on 13.3 to confirm it’s still ok and that the update didn’t break something (don’t think so though)?
Nevermind, I did the update, it still works on 13.3

have you tried restarting your computer post install ? normally restarting SU might help, but hey, why not the whole computer right ?

I’ve rebooted still not working. I’m I not using it correctly (it’s been sometime since I’ve had to use SU)? I selected the complete object, went to Extensions open Cutlist, set it to my specifications and hit run. Nothing happens

Dave will help you more than me here, the extension works, it lauches, but you’re probably missing a step somewhere, maybe in material parameters, or you have groups / componnents / raw geometry, idk how it works in detail. I’ve used the more recent opencutlist recently, but never this one :confused:

but yeah, from what you describing, the “package” is working, just not with your file.

As I wrote before, the extension does work fine in SU2023. I’ve used it in every version of SketchUp since it was originally released and it’s my favorite.

Share the SketchUp file so we can see what it is you are trying to get a cutlist from.

Cutlist reports on solid objects in your model. Are the parts in your model SketchUp solids?

They actually don’t have to be solids but they do have to be objects (groups, components).

1 Like