Cursor not changing to selected Tool icon

osx
mac
magicmouse

#1

Can some one tell me why the cursor doesn’t change to the tool icon after selecting any tool? Use to work. This in 2015 Make


Cursor not showing current tool with SU2017
#2

Even after moving the cursor into the drawing area ?

What platform (Mac or Windows) ?
What OS version ?

If Windows: 32bit or 64bit ?

Are you running any special mouse software ? (USB OverDrive, etc.)


#3

I see it for just a split second when moving into drawing area and then it is gone.

Mac Yosemite 10.10.1

I am using Magic Prefs. I just turned it off and still had the issue.

Just restarted my computer and it now works even with Magic Prefs. Installing the last update to Sketchup must have needed a restart.
Ken


#4

Did anyone find a fix for this issue? It is happening to me all the time, I just have an ordinary pointer cursor, with an instantaneous flash of the tool cursor when I change tool. It then reverts to the pointer.

I have Sketchup Pro 15.3.329 on OS X 10.10.5 running on an iMac with Retina display (MD Radeon R9 M290X 2048 MB)

I have restarted, rebooted… no change. I don’t have Magic Prefs or any other additional mouse software. Just a Magic Mouse.


#5

It is still working for me. I now am using OS X 10.11 El Capitan. You might try these two things. https://discussions.apple.com/docs/DOC-3603
They are good things top alway try.

Ken


#6

Same problem here. I select a tool, after a few seconds it’s the arrow again. Sometimes after having pressed a modifiera, sometimes just because.

Big problem, since I repeatedly find myself assuming I am in select mode, only to zoom-to-click, start a line, move, pushpull etc by mistake when I just want to select something…

Solution? Thanks.

(MacOS Sierra 10.12.4 on a MBP late 2016.)