Cursor not changing to tool's icon

Since a couple of weeks ago, my cursor stays the same (default arrow/select) no matter what tools I’m using so it gets confusing sometimes. This is the first time it’s happened to me although I’ve seen old posts (latest from 2018) on the same topic but nobody seems to have solved the problem. Is it just a glitch that resolves itself? If not, how do I fix it?

So it was working and now it’s not? This is in SketchUp 2020 as indicated in your profile? The thing to do is look at what changed on your computer at the time the cursors started misbehaving. SketchUp 2020 didn’t. So perhaps a Windows update? You could try repairing the SketchUp installation. If you don’t have the installer get it from sketchup.com/download/all Then right click on it, choose Run as administrator and choose the Repair option. After that completes, do a cold reboot of your computer. That is, power it off completely wait 10 seconds and power it on again. See if that sorts it out.

We did move offices recently and my remote desktop was temporarily out of service so it could be that. My Windows cursor also changed so it could have been due to the Windows update. I’ll try what you suggest about running a repair. Hope nothing else goes wrong in the process.

I did a repair and restarted my computer but the problem with the cursor has not been resolved. What now?

I guess look at what has changed on your computer after it last worked correctly. Can you roll the computer back to a prior point in time?

Using remote software can cause these issues, I think.
What software is used? Perhaps they have update.