Ctrl+C doesnt work in the Entity Info box - is that normal?

Anyone able to test that for me?
I think it used to work (maybe 2021 version?) but doesn’t work for me now.

I often to copy & paste values from SU into excel or my calculator app…would be nice for it to work as it’s faster than right-click → copy.

Strangely, when I use Ctrl+C on other boxes, such as the material name, they do work as expected.


Works for me.

Do you highlight the text in the Entity Info field, like a component’s name, a face’s area, a solid volume, an edge’s length or a circle’s radius, before copying?

If a field contains black text on a white background, it means that it is open for editing or copying.

It works very well. I just tried copying a component’s name and pasting it into an Excel cell and a face’s area copied in a Word document. No problem.


I highlight the section in yellow and try to Ctrl+C then Ctrl+V
It does show a “selection” highlight effect, just like usual editable text.

Area is a non editable value and yes, ctrl c doesn’t work on it while Right click copy does.
Not something I have ever used so I can’t say if it is new or not.
You mention it may have worked in 2021 but you have 2021 as your version in your profile, if that is wrong can you update it.

Ok, I fired up my older PC running 2021 and you are correct that ctrl c does work in 2021 but not in 2022.

1 Like

thanks for checking - im relieved that i wasn’t imagining things (again)

@colin (sorry to @ you again) but is this a bug, feature or unintended consequence?


Happy SU anniversary Box.


I see that the OP is using SU on a Windows machine.

On my Mac, it works as expected, for example : Cmd-C, Cmd-V for copy and then paste.

I found the corresponding bug report. Seems it was reported because copy and paste from certain extensions wasn’t working. Turned out to be a more general problem when doing Ctrl-C in text fields that are read only.

It was fixed internally some time ago, and should be working ok whenever we release an update.

1 Like

Excellent I’m so happy…this little thing has been bugging me for ages
Thank you!