Help Needed: Entity Info Window does not update properly


#1

Hi all,

Hope you can help with the problem I’m having with SU2015, Mac version. This isn’t the same as the window getting messed up. In my case, if I select an object in the model, the Entity Info window continues to show nothing selected. Resizing the window doesn’t help, nor minimizing and maximizing. Resetting the workspace usually helps, and if not I quit and then restart. Both are big time wasters, and the problem inevitably comes back.

I’ve also had problems with the layer window not letting me un-select layers…but that will be for another day.


#2

It helps to tell us exactly what you’re working with.
Make or Pro
Exact version number
OS X version number


#3

I don’t mean to insult you, but are you sure the selection tool is active at the time? This might not be your fault - I’ve had occasions when the activation of a tool mysteriously failed or delayed.

Also, have you tried disabling all extensions and plugins to see if the problem then goes away?


#4

Thanks for the replies, sorry I didn’t provide more info:
I am using the SU 2015 Pro version 15.3.329 (latest version)
MacOS 10.2.2 on a MacBookPro, 16GB Ram.

slbaumgartner
No insult taken. Definitely selected, and I can select many items - the items are highlighted in the model as being selected, and if a component/group is selected I can then double click and edit. I have noticed that the Entity Info dialog is slow to respond at times, too.

I have not tried disabling the plugins yet, good suggestion. I have a lot, but all come from the Warehouse (and I make a habit of updating them). They are indispensable to me, but I’ll check that.

Other important note: the model I have seen it on most, but not exclusively, is big - about 150MB, with more than 3.6 million faces, 26,000 component instances. It may simply be that the model size causes SU to delay showing what is selected. Still, it doesn’t happen all the time, and once it starts I can’t stop it short of resetting the workspace or quitting and restarting. I never saw this in 2014 (or any version since v8, when SU got to be ‘good enough’ to work with big models.

I was interested to see if anyone else had this problem. I know the Entity Info panel on the initial Mac 2015 release could get messed up, it seems that there may still be a bug in the code.


#5

Is 10.2.2 a typo?

SketchUp 2015 Compatibility Changes — SketchUp Hardware and Software Requirements

" With the release of SketchUp 2015 we’ve removed support for Windows Vista, Windows XP and OS X 10.7 (Lion) and earlier. "

Reference:


#6

10.10.2 is the latest release of Mac OS X, so I hope that was a typo! It works fine for me with SketchUp 2015 on a MacBook Pro Retina (mid 2012) 8GB RAM.

@sbolin, you could be right about size or complexity of the model causing a delay, especially if there are plugins that add observers. I haven’t seen that issue, but my models are a lot smaller than yours.


#7

On mac the are some issues with the entity info dialog. You can fix this by resetting your workspace


#8

Hi Sbolin,

You’re not alone with that problem, I run into that with SU 2014 on windows 8.1 pro.

It only happens when I import DXF or STL files.

I find that I need to save the SKP file, close SU and then when I re-open the file that seems to restore functionality to the entity info screen.

It seems that it began occurring after a windows update.

That is all that I have to add to this discussion.


#9

Thanks for all the tips.

Yes, I’m on 10.10.2. :flushed:

I tried turning off all extensions, and didn’t run into the problem, but didn’t really use SU that much that day. That said, I do wonder if maybe it is some problem with TT’s Selection Toys. I loaded all my extensions except for this one and didn’t see the problem. But I can’t live without Selection Toys, so I’ll put up with any problems. Right now resetting the workspace is the best fix, since it is reliable.

Thanks for all the help, much appreciated.


#10

This is interesting, because most of the models my office use start out life as ACAD files that we import (but then change a lot). If resetting the workspace doesn’t work I’ll try closing and re-opening the file (really should have thought of that). Thanks very much for the tip.


#11

You sound like an experienced user, but in case it helps, I’ll share that when I was having problems recently the advice I got here pointed to my graphics card. This website that was shared with me illustrated how woefully inadequate my card was. Replacing it solved the problem.

Also not mentioned above is to use layers to hide whatever’s not currently necessary to make your model more nimble, given the large size.