Entity Info Box not showing properly


#1

Ever since upgrading to Sketchup 2015 the Entity Info box is not showing the top part of the window properly.
(image deleted… I’m a new user :blush: )
When I select a face or an edge of an item then the top part of the window nearly disappears altogether.

I can grab the bottom right corner and drag the box wider and narrower, but not deeper !
It makes no difference if I am showing the secondary pane or not.

I have tried resetting the workspace to no effect. I have reinstalled Sketchup 2015 ( I discovered that 15.1 was available even though the “Check Web for update…” said I was up to date with 15.0)
I am running Sketchup on a MacBook Pro, OS X Yosemite 10.10.1

Has anyone else had this problem? I don’t see any similar posts anywhere.
Any suggestions as to how to fix it?


#2

It’s a know occurance with window size preferences on OS X, and the search function gives very well matching results:


SketchUp → Preferences → Workspace → Reset workspace


#3

Thank you, Aetilius, I did read that post.
…but as I said. Resetting the workspace does not fix it for me.
Maybe because I am running Sketchup Pro 2015 on OS X 10.10.1 ?


#4

ugh… you may have a corrupted .plist… i know how to reset the whole thing but unfortunately, doing that will make sketchup act like a brand new install and all other preferences will reset to default…

depending on your setup, this could be very time consuming to get everything back to your liking.


here’s how to do it if you want to go that route…

• quit sketchup
• open Terminal.app (Applications/ Utilities)
• type or copy/paste the following in terminal then press <return>

defaults delete com.sketchup.SketchUp.2015

• relaunch sketchup
you’ll now have a brand new sketchup :slight_smile: (well, all your plugins and custom materials etc will still be there… it doesn’t delete those things… just resets the preferences is all)



some other things you can do first to save&restore your current .plist.

• navigate to:
~(user)/Library/ Preferences

• locate the file: com.sketchup.SketchUp.2015.plist

• copy the file to your desktop (option key + drag&drop will duplicate it)


now, to restore this .plist:

• quit sketchup
• go to the Preferences folder again and drag com.sketchup.SketchUp.2015.plist to the trash
• move the previously copied file from the desktop back to the Preferences folder
• using terminal.app again, use:

defaults read com.sketchup.SketchUp.2015

• relaunch sketchup and the preferences will be in the same state as they were when you first copied them (with the messed up entity info panel)


there’s probably a way to reset only the entity info panel in the .plist but i don’t know how.


How to add Cubic Feet to Entity Info - it used to be there
#5

Jeff, you got an extra path layer “Application Support” in there, the plist is in ~/Library/Preferences

If very bold, you could manually edit the .plist file (it is non-compiled XML). The keys relevant to the Entity Info panel are EntityInfoPanel_frame, EntityInfoPanel_viewsize, and EntityInfoPanel_state. My guess is that EntityInfoPanel_viewsize has been corrupted. It should have two values separated by a space. The first is the width and the second is the height (in display points) of the main part of the panel. However, if you go that route it is essential to save a copy of the plist somewhere safe first, since the proper interpretation of these fields is not documented and you could make SketchUp unstable if you mess up the file. Also SketchUp must not be running while you do this, as it reads the plist only when SU starts and overwrites it when SU closes.


#6

oops. fixed. thanks.


#7

I tried both your fixes… …I tried & …I tried.
It was certainly interesting to learn how to do these things, but neither of them worked. Every time I reset the .plist either by deleting via the terminal command or by editing the EntityInfoPanel_viewsize it seemed to be reset to the same as before.

In the end I decided to download AppCleaner and I deleted anything to do with SketchUp15 and all previous versions and straggly bits that it could find.

IT WORKED… Yeessss!

Thank you for all your help :smile:
Rory


#8

when you did that, did the rest of the preferences reset?
if so, it sounds extra strange that the entity info panel was still messed up.

(it used to be, you could just trash the .plist and a new one would generate… then they made it so there were temp copies of it which would replace the trashed one… maybe yosemite is different yet again?)

glad you got it sorted out… still, i kind of think these sort of issues shouldn’t be happening in the software :wink:


#9

Yes. Preferences were reset.
I had a look for the com.ketchup.SketchUp.2015.plist file just to make sure it was there. I copied it as instructed and had a look inside the copy with Text Wrangler and I found the EntityInfoPanel_viewsize. …just to see if I could.
I then followed your instructions in terminal, but I was surprised that the .plist file was still there in the /Library/Preferences folder. I deleted it again in Terminal and Terminal said it could not be found.
I fired up SU15 but the Entity Info window was still not working properly.
Next I tried editing the EntityInfoPanel_viewsize as suggested by slbaumgartner. I succeeded in editing it, but again when I fired up SU15 the Entity Info window was still not working. on all occasions when I looked into the .plist file the EntityInfoPanel_viewsize numbers had reverted to what I had before.

Before reverting to this esteemed forum for more help I thought I had better try the ultimate deletion and reinstallment. I did this with AppCleaner and found that there were all sorts of leftover files from at least 3 previous versions of SketchUp. I deleted everything, emptied the trash and restarted the computer. I downloaded the latest version of Sketchup15 again and installed it. Everything worked properly and now I am finding my old extensions and resetting various preferences.

I have just looked at the new EntityInfoPanel_viewsize in the .plist and the numbers are quite different.

I think the lesson here is to do a proper deletion of old versions when a new version comes along. I naively assume that should happen automatically. Lesson learned !