Entity Info Window Goes Off Screen


#1

This has been a recurring problem since before version 8. At some point in a sketch the Entity Info window will move to 0,0 on the screen OR whatever the coordinates are for the lower left corner of the screen.

It doesn’t seem to be sketch specific, because loading a different sketch does not bring it back on screen.

I know it is in the upper left, because sometimes the keyboard shortcut will show the bottom of the window. I can then adjust the sizing of the window, but can never move the window.

The only way I’ve been able to get it back is to shut down Sketchup, but that doesn’t stop the behavior.

iMAC 24-inch, Early 2009
Processor 2.66 GHz Intel Core 2 Duo
Memory 8 GB 1067 MHz DDR3
Graphics NVIDIA GeForce 9400 256 MB
Software OS X 10.9.4 (13E28)


#2

Does it help to Reset Workspace? Preferences… --> Workspace --> Reset Workspace

I jump between different external monitors and screens. I have to reset the workspace often to get dialogs back on the screen where they should be.


#3

Thanks for the reply. I neglected to mention that Reset Workspace worked for me, but I had to restart SketchUp for it to work.


#4

That is annoying! Does changing your mac screen resolution from the Display Preferences help? It is still annoying, but I sometimes need to do that. I will change the resolution, drag the pesky wandering dialogs to the center, then reset the resolution back.


#5

Annoying is the word for this problem.

Changing screen resolution doesn’t have any affect (on the problem.)

The Entity Info window moves to 0,0 and is “behind” the Sketchup menu bar most of the time.

So far, it is only this window that is affected for me. It happens occasionally for me.

Reset Workspace is the only thing that “fixes” it.


#6

I have the same problem on my MacBook Air and I reported the problem a few months ago to the SketchUp Team by mail and I was hoping that the problem would be solved with SketchUp 2015 but it’s still here.

And to reset the workspace everytime isn’t the solution.


#7

Same problem here on 2014 MacBook Pro / OSX Mavericks / SU Pro 2015.

With an additional issue: now it’s started splatting when I try to ‘Reset Workspace’. Pretty frustrating.[I’ve submitted that bugs plat reports for the last few splats]

Maybe someone from the SketchUp team can explain why this issue (disappearing dialog boxes) is still unresolved so many years later? Is it that deep? If I remember correctly, at the time the Reset Workspace function was a patch until the underlying problem was fixed.


#8

Hi db11 - I just looked at your “reset workspace” crash - it crashed while Cocoa (the underlying Mac UI framework) was drawing some UI objects, but it doesn’t even tell me which UI element it was drawing. So, I can’t offer any advice there.

Regarding the entity info panel, the one workflow that I know causes an issue is when the entity info panel is minimized, the current document is changed, and then the panel is expanded again. I would expect better behavior from the dialog if it’s left expanded all of the time. If you find a different workflow that causes the dialog to go haywire, please report it and I’ll add it to our bug system. We were planning to fix this bug for the 2015 release but got sidetracked by Yosemite and other Apple-specific changes.


#9

Thanks for the reply Marc. I’ll try leaving the entity info dialog expanded and see if it helps the problem. I had a couple of more crashes yesterday (dismissed the bugsplat report instead of sending it — my bad)

We were planning to fix this bug for the 2015 release but got sidetracked by Yosemite and other Apple-specific changes.

I’m glad to hear that it’s slated for a fix. I know it’s not the biggest bug in the app, but it gets annoying to have to reset the workspace a dozen times a day… and that was before it started crashing on me.

I know you guys have been kept busy by major under-the-hood changes this cycle, but small interface bugs like this add a large amount of friction to usability — because they’re encountered so often in daily workflow.

Doug


#10

Since my original post, I haven’t had a single incident while keeping the entity info panel expanded all the time. I usually keep a stack of the layers, components and entity panels in that order from top to bottom; entity always open.


#11

Thanks for the update, it’s very helpful.
-m


#12

Im seeing this issue also on mac. Most of the time when you visit other app and return to SU. Pretty annoying since this happens all through the day. I dont like to reset it cause i need to put all the panels back in place. I save, quite and restart.

I also have a issue that the entity info panel shows half, this doesnt update after restart.


#13

Are you seeing the bug where the entity info dialog disappears, and then re-appears at the top-left of the screen after restarting SketchUp? This should have been fixed in one of the maintenance releases for SketchUp 2015 - can you double-check to make sure that you’re running the latest version of SketchUp? (SketchUp->“About SketchUp”, and in the resulting dialog there should be a version number like 15.3.329.

Marc


#14

Yes, im running that version. The entity window, as like the others, disappears to a xy of 0,0. i need to restart SU to get them back at regular positions. Sometimes the entity panel also show half of the regular size, so cant see or fill name of group/comp…


#15

I’m still having this issue with Macbook pro running El Captain and SU 2015 pro. Really frustrating to still have this bug that was never fixed!


#16

Hi. I just downloaded SketchUp 2017, Make with temporary Pro. Loving it – but I have a problem: I accidentally minimized the entity pane and can’t get it back, by “resetting workspace” or by shutting down and restarting SketchUp. Any ideas for me ? Thanks in advance. Steve


#17

Did you try turning it on again in the Window menu?


#18

Hi, Dave. Well, when I select it in the Window menu, it appears, but at its
smallest size, which just says “No selection.”

Steve


#19

Entity Info will show “No selection” unless you’ve selected an entity in the model space.


#20

I’ve tried “select all” under Edit, and “select” under Tools. Everything I do minimizes the Entity pane, or closes it.

I’m in the middle of a model, and have done nothing different besides accidentally reducing the options in the Entity pane, and then reducing it further, after which I’m stuck. I can continue to model, of course, but I’ve been working with colors selected by axis, and I’m ready to return to all one color. I wonder if I’m suffering a failure to delete the one previous version of SketchUp that may still be in my computer – as suggested by posts earlier in this thread ?