Entity Info Window won't resize


#1

Hi everyone,

This seems to be an issue that others have come across before, but i’m having a hard time solving it.

I’m using SU Make 2015 on my 2009 Mac Mini running OS X Yosemite 10.10.3.

Since upgrading to SU 15.3.329 the Entity Info Window refuses to resize vertically. Ive attached the screenshot to demonstrate what i mean. In this case it has clipped the bottom part of the window that shows area, but often clips it even further up.

Things i’ve tried so far:

  1. Dragging the triangle in the bottom corner, this will allow horizontal resizing but not vertical.
  2. Minimising then maximising the window.
  3. Toggling the details option in the top right hand corner on and off.
  4. Resetting the workspace.
  5. Uninstalling and reinstalling SU 15.
  6. Uninstalling SU15 and installing SU14, irritatingly this still produces the same error!
  7. Opening the Entity Info window in old drawings and new.

If anyone has any ideas on this, i’d really like to hear them.

Thanks


#2

This is a previously reported bug on the Mac. It happens when SketchUp’s preferences (.plist) file gets a bad set of values for the size of the Entity Info window, though so far as I am aware nobody knows exactly what provokes this error. Since your workspace reset did not work, you will have to blow away the preferences file and let SketchUp regenerate it. This requires some comfort with using the Terminal Window in Mac OS X. To do so:

  1. Make a note of any SketchUp preferences you have set that matter to you
  2. quit SketchUp
  3. open a Terminal window
  4. type “defaults delete com.sketchup.SketchUp.2015; killall cfprefsd”
    (without the quotes, but caps matter. The first part blows away the prefs, the second clears the system’s preferences cache. If you skip the second part, the system will just restore the previous prefs from its cache.)
  5. restart SketchUp and verify that the Entity Info window is “healed”
  6. re-enter the preferences you noted in step 1

#3

Thanks, but unfortunately no joy.

I uninstalled SU15, used Dr. Cleaner to clear out the files, copied and pasted that script into a Terminal Window, and downloaded and installed a fresh copy.

It went through its normal first time usage type setup questions and then opened my most recent drawing! It would seem that its still “remembering” some settings somewhere, including the extension that i had installed.

And of course, the clipping problem still persists.

Any more ideas?

Thanks


#4

Got it!!

AppCleaner saved the day!
Thanks slbaumgartner for the help anyway.


#5

Remembered documents is an OS thing, not a SketchUp thing. Plenty written about it on the internets, so I’ll save the space here and allow you to go find it.


#6

I didn’t see any of those links Barry mentions, but there are a couple of things that we’ve heard reported to fix it…

  • Use the Reset Workspace found at SketchUp > Preferences > Workspaces
  • Reset preferences by deleting the plist for SketchUp (found within the uninstall article in our Knowledge Center.)

If we can ever find a way of recreating the issue we’ll try to add more information, but as-of-yet it doesn’t happen to everyone or all of the time so it’s hard to reproduce.


#7

The recently opened documents list is kept in a separate plist (com.sketchup.SketchUp.2015.LSSharedFileList.plist). Deleting SketchUp’s preferences plist has no effect on it.


#8

And plist’s are cached by Core Foundation Preferences daemon (cfprefsd), so even if they were deleted, they’ll persist unless you kill cfprefsd or log out and back in.