Creating faces for floors

I’m trying to creats floors for different rooms on a model and several of the faces are not whole faces. Any suggestions how to fix this welcome, thanks guys

Share your model so we can see what you are referring to.

Are you still using SketchUp 2017 Make as indicated in your forum profile? What graphis card?

I just started using SKU Pro 2023. I’ve brought in a CAD file from AutoCAD and began drawing up the walls. I created a rectangle overall for the floor model but that didn’t work so I began to draw trangles in each separate room however the faces are not complets, there are gaps…

Please update your forum profile.

That’s not very unusual for imported CAD linework. Again, share the .skp file so we can see what you’ve got going on and give you a way to fix it.

I’ll do it later as it’s on a different desktop. Thanks :slight_smile:

I tried sharing the file with you but I’ve no idea where it’s gone… I went to file, trimble connect, publish model and as I said, I don’t know where it’s gone. Can you tell me how to get the file to you?

Publishing the model to Trimble Connect only uploads it into your Trimble Connect storage. That’s not sharing it with anyone. If the file size is less than 16 Mb drag the .skp file into a reply here. If it’s larger, upload it to DropBox or We Transfer and share the link.

How can I sent it to you via Wetransfer without an email address?

I just started using SKU 2023 yesterday, it’s going to take me a while to figure this out. I’ve no idea how to drag the skp file into this reply box, sorry.

Copy the link and paste it in a reply here.

Maybe you should go through the ttorials at learn.sketchup.com

It’s exactly like dragging and dropping any other file on a computer.

I’ll try to figure this out I think I know what the issue is now. Thank you for replying to me, I appreciate it.

On wetransfer you click the three blue dots to switch from needing an email, to getting a link instead.

Thanks Colin :wink:

Hi Dave,
Here’s a Wetransfer link to the model. I’ve no idea how to fix this in this version of sku. I’ve deleted it over and over and started from the begining but the gaps in the floor keep reappearing, no always in the same place just FYI. WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

Dave may be offline since he’s in a different time zone. Looking at the file, it appears that there was some hidden lines that may have been overlapping or connected to your cad floor plan and then stretched across the faces after having moved everything away from the origin.


If you’re familiar with AutoCAD and have access to the CAD file, it may be best to start fresh and clean by grouping or isolating just your wall linework in CAD so that it stays ‘protected’ from everything else after importing into SU.

Another option is to spend a bit of time in CAD cleaning up your file so that you have only what you need to work with and nothing else. Unlike CAD layers, SketchUp doesn’t separate loose geometry. Loose geometry needs to be grouped and then assigned to a Tag for proper organization. Simply turning an AutoCad layer off won’t prevent it from intersecting or interacting with the layers/linework left on.

As mentioned previously, we have a course specifically designed to help troubleshoot the CAD to SU process - 3 Ways to Boost Your CAD to 3D Workflow

Since you’re new to SU, I’d also recommend the ‘Fundamentals’ lessons so that you’ll have your basics covered as well.

Hi Eric,
Perfect and thank you; I’ll sort out the CAD file and check out the course you suggested.

1 Like

Hi Eric,
I’ve just gone through the ‘3 Ways to Boost your CAD to 3D Workflow’ and I have a question.

What are you thoughts on this, Instead of going through any of the workflows how about using a jpeg image of the 2D Cad file and use this to build the 3D Model?

it’s imprecise.
when building from a jpg, either use it as a reference but build using proper dimensions, or build using the jpg and make an imprecise model.

And since my pizza is not here yet, an example.

this plan I use in class. we import it, compare dwg and su, and model it.
we can do that, because it’s a dwg, therefore it’s precise, you can snap lines and faces on it.


if I were to import it as an image, zooming on it, I would have major precision issues. Do I place my lines on the corner of the red wall ? in the middle of the blue lines ?

you’ll have similar issues with scanned plans, ink bleeds, scans are more or less pixelated…


how to be 100% precise in these conditions ?