Compatibility issue between Ryzen 9 laptop and SketchUp, seeking solutions

Hi everyone,

I am facing a compatibility issue between my Ryzen 9 laptop and SketchUp, as well as some other programming software. I’m hoping to find some guidance on how to fix this problem. Here are the details:

Laptop Specs:

Model: Ryzen 9 5900HX

RAM: 8 GB Ram

GPU: NVIDIA GeForce RTX 3080

Operating System: Windows 10

SketchUp 2021

Other programming software: Visual Studio Code, Android Studio

Issue Description:

I recently purchased a Ryzen 9 laptop with the intention of using it for both 3D modeling in SketchUp and programming in various software. However, I’m encountering compatibility issues, particularly with SketchUp.

The problem arises when I try to launch SketchUp. It either crashes during startup or freezes while performing certain tasks. Additionally, when running other programming software, I have noticed occasional lags or delays that make it difficult to work efficiently.

Troubleshooting Steps Taken:

Reinstalling SketchUp: I tried reinstalling SketchUp, hoping that it might resolve any software-related issues, but unfortunately, the problem persists.

Updating GPU Drivers: I made sure to update the GPU drivers to the latest version provided by NVIDIA. This helped with some other software, but SketchUp is still exhibiting the same compatibility issue.

Checking System Requirements: I reviewed the system requirements for SketchUp and my laptop meets all the recommended specifications. However, I am still facing these compatibility issues. I am reaching out to this community in the hopes that someone has encountered a similar problem or has knowledge about how to resolve this compatibility issue. I would greatly appreciate any suggestions or advice on how to fix this. If you need any additional information about my laptop, software versions, or any error messages I receive, please let me know, and I will provide them promptly.

Thank you in advance for your help!

Best regards,

Jessica Shepherd

You could try reinstalling using “Run as administrator”. It may say “repair” when selected. Go with it.

In the Nvidia Control Panel, you may want to add Trimble SketchUp and select Nvidia GeForce… under OpenGL rendering GPU.

I’ve seen people suggesting switching to the Studio drivers rather than the Gaming Drivers.

Use a fast style in SU. Turn off Profiles under Styles ->Edit.

The processor doesn’t have compatibility issues, anyways you should update the drivers of the CPU also, maybe the gpu could be causing this, I recommend you to download the GeForce experience software from the Nvidia website, install it and from the program download and install the studio drivers, you may have installed the gaming ones, I’ve had issues with other softwares when I install the gaming instead of the studio drivers.

These system specs should be great for using SketchUp.

As others are saying, could be that SketchUp isn’t using the RTX3080 and using the internal Radeon graphics instead? Just force SketchUp to use the rtx3080 using the NVIDIA settings panel.

Also, does this happen when the adapter is plugged in? The Lenovo’s sometimes have some smart software settings that throttle / switch the graphics settings depending on your power profile or when you’re not connected to the adapter and are using the battery.

Maybe try testing a different power option: test using balanced instead of best performance or vice versa. Strange enough, balanced gives me better performance in some apps.

8GB of ram seems like a rather small amount to pair with a 3080 RTX, is that correct?

1 Like

You’re right! The 8GB could also be the reason the system is slow indeed - 8 Gb is relatively low. For a workstation I would always start at 32Gb so you can have many programs open; SketchUp, email, Office software, Image software etc. With 8Gb, the system would fairly quick run out of memory and start swapping to ‘disc’ which could be the cause for the lags and delays as well.

Easy to test by opening the Task Manager and look what the memory & disc are doing when the lags and delays start to happen.

1 Like

Yep, I’m just browsing the net with outlook open and the usual background services doing things and I’m using 21GB of my 64GB being used.