Close Layer in all scene at once


#1

I don’t know if there is a plugin for that feature. I’m looking for option where I can close (make invisible) a layer in all scenes at once. To avoid re-updating every scene one by one.

I have the plugin “Auto invisible layer ON/OFF” It works great but I’m looking for something similar but once the layer is already created. I’m working with template of over 50 layers, so I rarelly have to create them.

I also installed Layer Management from D Bur. The Layers Config Save-Load works great but still doesn’t have that feature.

For the Acad user, i’m looking for the option: VP Freeze Layer … in All viewports. An option you have when right-click on a layer.

Cheers


#2

This action is certainly feasible and fairly simple to program via the Ruby API, so try searching the Extension Warehouse, SketchUcation’s Plugin Store, and the Ruby Depot to see if any of the other available layer managers support it.


#3

Here is an old one of mine that might help.

Usage:Extensions/SDM Tools>Misc Tool>Hide_Show_Scene_Layers.

Select the Layer or Layers from multiple selection list.
Select Hide or Show option
Click Hide/Show button

The selected layers will be hidden or shown in ALL scenes.
Hide_Show Scene Layers.rb (4.2 KB)


#4

Yes that works!

THANKS Sam


#5

@DanRathbun and @john_mcclenahan turned me onto this plugin to help manage layers visibility in scenes. It’s been very useful.

https://sketchucation.com/plugin/832-jf_add_layer3


#6

JF Add Layer has been a real help in complex projects.


#7

Sam, your plugin works for a while and stop working suddently! ;((( I reinstall it (just put the .rb file into plugin folder) and it still not working. Here’s what happen: The first option window open, I pick the layer, tick the box “Hide” and click on “Hide/Show” and nothing happen! Do you have an idea what happen? it used to worked!!


#8

No way of knowing without the model or additional info.

Open the Ruby Console, Windows>Ruby Console, before using the plugin to catch any error messages. If there are some, copy and paste them into your reply.


#9

Check my snapshot. I clicked a few time and choose different layers.

Layer=Layer4&Radio=Show&submit=Hide/Show
Layer=Layer4
Radio=Show
submit=Hide/Show


#10

The selection list is a multiple select. Use the Shift and/or Ctrl key to select all the layers at one time.


#11

ok it works, I was doing something wrong on my side!!! Cheers
That’s what happen when you work late on friday night!! :expressionless:


#12

Hello Mitch, problem is still there here. When I click HIDE, nothing happen again! The ruby Console shows: Layer=Details+1&Radio=Hide&submit=Hide/Show
Layer=Details+1
Radio=Hide
submit=Hide/Show

Could it be because of another plugin install like: Layer Manager from D.Bur?


#13

Possibly but doubtful.

Is “Details+1” a legitimate layer?

Or is the name “Details 1”. For some reason spaces are sent to the call_back routine as +'s.
Fixed that bug.

Hide_Show Scene Layers.rb (4.2 KB)


#14

Ah HA! voila! Yes, the problem was happening only with the layer with a space… and Yes, your new version fixed the problem.

THANKS Sam!


#15

Hello Sam, I just installed SU2018, the plugin don’t seems to work in it. Can you make it work for 2018. I really like that plugin! CHEERS


#16

You can try VisMap2 by MartinRinehart
It is an oldie but a goodie. I havent had to use it in a while but it help you out. It is great when you have a lot of layers linked to many different scenes.

This was never converted into the RBZ format so you will have to install it the old fashion way.

Cheers
CD