Changing text from Thingiverse object

Pardon the ignorance. I checked this forum for something like this and couldn’t find anything like it. I am trying to clear the text from a 3D object ( http://www.thingiverse.com/thing:1442741 ) and add a logo or new text. I contacted the creator for help but who knows if he’s even active any more.

TLDR: Looking to clear text from this tool and add my own or leave it blank.

Thanks for the help.

So you want to remove VTK from the model and put in something else like my initials?

Import the file into SketchUp first. I’d use Push/Pull to pull the faces in the bottoms of the letters up and then erase their edges. You can then use 3D text to make new letters to emboss the part.

I’d run ThomThom’s CleanUp3 before editing the model.

1 Like

Thanks for the reply, I tried to do that but unfortunately there are tons of different sectors that have to be raised and it always ends up not being level or there will be a slight raised edge that I can’t get rid of. I have been working on this for 2 days solid. I am IT by trade but I feel extremely dumb trying to work with this. Must have downloaded 5 random free CAD programs trying to fix this tiny little bit of text.

I guess I don’t understand what the problem is. Maybe you need to run ThomThom’s CleanUp3 first. The extension is available through the Extension Warehouse which you can access through the Window menu in SU.

I’ll give that a shot, Thanks for the pointers mate.

Another approach you might use to get rid of the existing letters after you run cleanup, is to delete the top face of the part. Select it and hit Delete. then triple click on the letters to select all of the attached geometry and hit Delete again. then use the Line tool to trace a line segment on the edge. This will “heal” the top face on the part and give you a fresh surface to work on.

This is what is holding me back. I don’t have too much experience with this program or with CAD in general. But when I try to adjust the layers I get tiny bits like seen highlighted in green http://i.imgur.com/nDvjaqo.png . So I would have to go through all of those ■■■■ lines and adjust them to the correct height.

That’s why I suggested running ThomThom’s CleanUp2. It’ll get rid of all the co-planar edges.

That plugin darkens the project and brings up a blank window that looks like it’s missing options.

Did you also install the required TTLib files?

Just looked, It is installed. And re booted my machine for good measure.

How did you check to see that the current TTLib files are installed?

Maybe @thomthom can tell us why you get the blank window.

Under the cleanup plugin I fallowed the link to the prerequisites and downloaded them from there. I’m going to reinstall them to see if anything changes.

Did you let the Extension Warehouse install them for you?

Yes I did. It said it was successful.

Just uninstalled Sketchup, reinstalled and re installed all plugins. Still the same deal.

Uninstalling and reinstalling SketchUp is usually a drastic step that doesn’t fix anything. I expect ThomThom will be along.

I figured if anything would fix it… The only plugins I have are STL import, Joint Push Pull and the cleaner along with it’s dependencies.

To be honest, the easiest solution would probably be to make the shape in 2d and then Pull it up the appropriate height.

To clean the name, the quickest way may be to break the face, then delete that section, triple click on the letters and delete them, then draw a line to patch the face:

2 Likes

unfortunately this is my second day with this software and i’m not that acquainted with it yet.
The most frustrating part about this is there looks to be simple ways to get this done but I don’t know any of them. I guess I need some more practice with this software.