CFileException 2 when trying to save in sketchup

I also have this issue, I have we’re a small company of 3 but regularly need to exchange or co-work on files and cloud storage is ideal for that. But I am unable to save to ivedrive folder (L:) All access rights are ok. And Skutchup files are the ONLY ones that cannot be saved to th Livedrive storage. I would also appreciate a solution from Livedrive for this.

Just ran into this problem using Dropbox folder mapped to a drive letter (in my case W:). I restarted Dropbox, but that had no effect. So, I “unmapped” the folder and then remapped it to the same - using VSubst - and that fixed the problem. I don’t know how the L:\ drive gets mapped for Live Drive, but if you can un-map it and the remap it, that should take care of the issue.

Before going to this solution, I tried saving directly to the Dropbox folder in C:\ and there was no problem. I suspect the issue is that Sketchup feels the connection is “poor” and tries to save the #.skb and then rename it.

I understand saving directly to Dropbox is not the preferred method, but I have been doing this without problems for almost 2 years.

I have been getting fairly consistent CFileException 2 errors trying to save directly to Dropbox since 10-27-2016 using SU Pro 2015. Using 2016 on the same directories and same files has only reproduced this error once since the issue began.

I am having the same exact issue. Using 2015 Pro.

CFileException 2 errors and 1.skb etc files generated. I have been using SketchUp and Dropbox for years with no problem…now this.

My temporary work around is to just PAUSE Dropbox sync while i am working. Then when i move on to something else, i RESUME sync. So far, no problems.

I understand this may not be possible if you are collaborating with others who need up to date files, but i am simply using DropBox to keep multiple machines synced, so it works for me.

Does anyone know if there is a thread somewhere else that addresses this that we can complain on? :wink:

Pretty much the same trouble right here… I have been using Dropbox for almost 2 years, and suddenly stop to work on my desktop computer… my tablet/pc Surface Pro4 still works correctly… I will appreciate if anyone has resolve this issue to share with the SketchUp Community.

Thank you in advance and Happy New Year!

The analysis given in many topics about this issue says it seems to result from slow response over the network when SketchUp saves to a non-local destination. Network response is going to vary from case to case and from time to time, even using the same computer and connection. So the fact that it worked before is not an indication it will always work.

That said, it certainly seems that SketchUp is overly sensitive to network timing. Hopefully the developers will someday get around to finding a way to reduce this problem. At the minimum it would be nice to detect that this is the cause and give a more intelligible explanation rather than the raw OS error code!

1 Like

… nevermind, the downgrade solution doesn’t work.

Has anyone found a solution or cause of this problem yet?

anyone can fix it?

I have this same issue. What is the status Trimble?

The fix is save locally and sync the Drop Box folder.

Bebore you save, go to dropbox icon and pause sync. after that you can save the file and finally reactivate sync again. That works for me, not that I like but it doesn’t gives you the errror code CFile Exception 2…

Hi, i’m having a problem with opening my sketchup file. It keeps showing CFile Exception2 then the location of the file. Is there anyway to open the file at all?

Is the file local or is it in cloud storage or a server?

It turned out to be a problem with the memory stick it was saved on. Luckily the file was saved from the memory stick by someone before the memory stick broke.

Hi, so what is your solution?

Huge problem CAN’T Save at all…Capture%202

You seem to be running quite a lot of plugins. Does the problem occur if you disable them?

Can’t tell you, I just reset the Windows 10

The tech support has not get back to me for days. need to get onto work. I solved by take a little risk of resetting Windows and uninstall everything on my pc, under window security “refresh window”

Now it saves… but downside, it is another day of reinstall everything…

Was doing some research this morning and posted this: