Can't view my models in AR

For some reason the models that I upload to the 3-D warehouse don’t show the option “ View in AR“
Even though the models are not private. can someone please help me, what am i doing wrong? Thank you so much.

Could you please provide a link to the online model?
Thank you

Hi here is a link

Here is the 3d Warehouse link

Possibly the file size is too large. Many of mine show that.

@TheGuz is the AR feature available to all users or only SketchUp Pro users?

I have sketchup pro subscription so i dont think its the problem.
Is it possible to view the “object” without the AR option?

When you open the “ view in AR “ option you can select “object” and then review the model very nicely without Having to connect to sketchup or anything.

Please correct your profile, then. It’s misleading.
Screenshot - 8_9_2022 , 7_36_42 AM

Yes. You can click on the 3D Model button on the image in the 3D Warehouse.


With which device are you attempting to view the model in AR with? A phone or headset connected to your computer?

Hmm, size can’t be the issue, just checked some other models from stavcohen312 which are bigger in filesize BUTT with the ar option…
I can’t find why the ar option is disabled for this model :confused:
I’ve tried exploding, rescaling, moving, etc. then uploading to 3dwarehouse butt every time without the ar feature.
Hope someone can solve this, i’m also getting curious what/why/when this issue occours.
Also have/had models which sometimes do and sometime don’t show the ar feature …

PS1 using SUP21 and chrome browser for 3dwarehouse.
PS2 SUP21 starts without problem, while drawing popup shows i need to login so i did, when trying to upload to 3dwarehouse i need to login (again?), but popup didnt remember my login details, so finally logged in again and now i’m wondering when i need to login again and again later today (since 28 days without login should be possible when offline, butt when online 28 days fly by in just a few hours? o.0)

Or is there an issue with the 3dwarehouse which also cousing this issue with ar features?

Maybe size isn’t the issue. Curiously though some of my models are indicated as too large and they aren’t that big.

Iphone , computer, ipad

Can someone notify the sketchup team maybe it is something only they can solve

Here is a link to SketchUp Viewer: SketchUp Viewer | SketchUp Help

SketchUp Viewer for Mobile is available on iOS (I use Android, so haven’t used the iOS version but it works on tablets and phones). The SU Viewer for Mobile has an AR mode. You can open models that you have saved to your device (or cloud, I believe) or Trimble account in the app and then view them in AR. You don’t need to upload them to the 3D Warehouse.

With SketchUp Viewer for VR you can open files on your computer to view in VR.

I don’t use Ipads, but see if you can open your model and then find a “View in AR” feature from within the app. edit: AR Viewing | SketchUp for iPad

Also, go to your Trimble account, My Products → View Included Applications where you can download the Viewer Apps that allow you to use AR.

I know but i am asking specifically about the option “view in AR” in 3d warehouse

65k polygons and 2 MB files size ought to be ok. I have a bug report in where even a 7.5 k polygons, 1 MB file, is failing to get the AR feature. I don’t see any updates in the bug report, I’m not sure if someone is investigating the problem.

So what can we do who can we talk to?

There isn’t anything you can do for now, but I will look at your file and the others that are failing for me, and see if I can tell what’s different about them.

בתאריך יום ג׳, 9 באוג׳ 2022 ב-21:28 מאת Colin Holgate via SketchUp Forum <>:

I don’t have final news yet, but some progress. There are two reasons for the AR feature to fail: the file it uses failed to be created, or the file is created but not linked in correctly.

The file not being created would potentially be a bigger problem, because it would suggest that there is something about some models that makes them not convert to the right format ok. That could take a lot of testing to find out what is different about those models.

The link not being made is, hopefully, a less difficult problem.

At the moment it’s looking like the file is created, but the model info page states that the file was not created, and therefore there is no link. The model info page needs to be convinced that in fact the file is there, ready to use.

The issue has been forwarded to the team who know more about the linking side of the problem.

The model opened in AR via SketchUp Viewer → 3D Warehouse (which is a download) for Android (tested on tablet).

After I uploaded it, I waited for the magic to be sprinkled for some time, but the “View AR” button never appeared.

I wondered why it would open via 3D Warehouse accessed through SU Pro or Web browser because those devices (on desktops/laptops mostly) aren’t well-suited for AR.

Anyway, I also tried on an Android phone with another account. It wouldn’t download at all. I tried turning privacy on and off but not luck (still got privacy message even though it was not private).

That’s my 2 cents.

Related question: Is the Legacy version of SketchUp Viewer for HoloLens still supported? I had trouble finding the executable awhile back after reinstalling Windows Holographic and now it seems that I can’t sign into Trimble Connect with HL1 Legacy Viewer.

Is there any update about the files not showing the option “view AR”? Most of my models are working in AR, but some are still not.