AR view in space does not work. Error


I have uploaded a few models in the SketchUp warehouse, and the AR view in space is not working. The models are not too complex, I viewed AR models from the warehouse that had way bigger polygon counts and file sizes than mine, and I can’t figure out where the problem is.

Error message: Couldn’t load object. Looks like there’s something wrong in this object.

Any ideas?

hmmm do you have the link of its warehouse page somewhere ?

You gave the link to the 3d model itself, but (at least on desktop), can’t check AR from there :slight_smile:

Yes, sure. Here it is: 3D Warehouse

I’m on an iphone SE2, last ios version, it took some time to load, and the transparency of the leaf material is not perfect, but it worked
(I scaled it to 50%, my living room isn’t that big)

check your phone for updates, and restart it maybe ? we tend to keep our phones on for weeks at a time, and sometimes a clean restart helps.

Asked for few coworkers to try this as well. 4 of them got the same error message as I did, and all of them are Android users. One was able to, with an iPhone.

It is strange because I am able to open AR in general, just not my models.

I suspect it relies on some external tools and packages. Since the A/R tool is also part of SU for ipad, I’m not surprised it’s fully functional on iOS. I guess the package isn’t compatible with some android releases ?

the original thread is here

there is a mention or ARCore, @TheGuz might have more infos on the tech needed.
also, the warehouse is growing these days, last weekend it was stuck, they had to catch up with the uploads, could also be they are working on it ?

I see the same issue with your model on my Android phone but I tried other models from the 3DWH and they work fine. I wonder if it has something to do with your specific models.

Capture d’écran 2023-09-07 à 15.25.22

could it be because it’s brand new ? older AR models could be made using an older version of the tool, and your model was made using the brand new update, not yet compatible with android ?

1 Like

That could be it, I checked some models in the warehouse that were uploaded today by other users, and I couldn’t open any of them, just the old models are working for me.

popped right up on my iPhone 13

Those of us who use apple devices must have some advantage…
We can’t use scan essentials but we can see the 3DWarehouse objects on our phone… :wink:

1 Like

I’m back with some testing. It looks like the problem is with Sketchup glb. file export. I uploaded the same model glb. files made by SketchUp / Blender to AR Myarstudio. Although the Blender file has some faulty textures(maybe because I don’t really know how to use Blender properly) I can view the model in space with my Android phone, while Sketchup export still comes with an error.

Hi, we are having the same problems. We have older models online that work fine in AR. We uploaded the same file again and the new uploads do not work in AR or need minutes to load, while old version took seconds.
So it seems to be a problem with process after upload.

Hi viva,

After 3 months I still have no proper solution for this. Since I have to do the AR model anyway, I model it with Sketchup, then export the glb file with Keyshot and upload it to Myarstudio to get the QR code. It is complicated workaround and costing additional money for cloud storage, so I am still having my fingers crossed that Sketchup team will fix this bug someday.

I just tried it with a Pixel 3XL (running Android 12) and got the “Couldn’t load object” error.
Tried with iPhone 13pro and it worked fine. Can you tell me what Android OS you and your coworkers are using? Rather, if they are also running Android 12 or earlier.