AR Viewer Not Working

I attempted to upload a model to the 3D Warehouse and then “View In AR”. I then scanned the QR code with my phone and tried to “View In Your Space” which kept crashing my phone. I attempted on my other Android with the same results.

I then dried downloading the Android version of SketchUp Viewer and paid the $9.99/year subscription to view my model in AR which crashes the app.

AR and SketchUp does not appear to be working correctly. Am I doing something wrong?

Today I tried the Android version of SketchUp Viewer with viewing my model with AR, it worked for a little while. I tried it again a few minutes later and it just keeps crashing and is very unstable, won’t activate my camera to show my model in AR.

When it did work, one feature that would be great is the ability to take a screenshot of the AR to save for future reference or share with others.

SketchUp Viewer sometimes gets stuck on the screen that says “Slowly move your device to scan the surface”

Also crashes with the error message in the other photo.