Can't see material windows

Hi!
When I clic create new material, normaly I have a window appear.
now I can’t see this windows and I have to escape because I can’t
do nothing.

Your help will appreciate, Thanks

Are you referring to this window?

Do you use several displays? Yesterday someone posted with this problem. Turns out that dialog was opening off screen. You can try Window>Preferences>Workspace, rest Workspace.

The other person had to edit the position in User/Appdata/Local/SketchUp/SketchUp 2019/SketchUp/PrivatePreferences.json.

I’ll hunt up their thread.

Hi Dave

Sometime, but normaly no. It’s about 14 years a work with Sketchup and never happen

See this thread.

Find the section in that file that shows the position. Report the X and Y locations. Mine shows like this:

        "ModalEditMaterialDlg": {
            "show": false,
            "sticky": false,
            "x": 1349,
            "y": 336

I have it here in the code writer, you talk about thatcode

Edit the file to the numbers I showed and reopen SketchUp. Then click on Create Material to open the dialog.

I edit file, close and re open Sketchup, but doesnt change

You still don’t see the Create Material dialog when you click that button?

Still don’t see the dialog when I clic the button

Try changing those x and y values to 100 and 100.

I change it to 100 x and y, close and open but still don’t see the dialog box

Did you install by Right Click Run as Admin?

1 Like

Yes and I can see all the change I made are there

Useful Windows trick:

To recover an off screen dialog, do what it takes so that the dialog should be showing, then press Alt and Space, and tap the M key. You can release those keys, and then tap any arrow key. Move your cursor around and the dialog will be attached to the cursor, ready for you to drop it off anywhere on the screen.

@colin that is a rough approximation of the fairly well known manual method of capturing an errant dialog.
But from what I know it normally only works on floating dialog (Preferences/model Info etc) rather than Tray options.

Could be, but I tested it on the new material dialog, and it does work for that one.

Interesting to know.

Oh yeah ! this trick work good. I will remember this one

Thanks for your help, very appreciated. two tums up

Could you show us a quick gif on how this works for you.