Can't add license in 2019 Pro

I work for a company and have been using 2018 Pro to do some work for them. The owner sent me the updated license info with authorization and such. I was hoping it would improve performance. But after installing it I cannot add new license. I tried:

-Going to add license page but the “button” that you are supposed to press does nothing so I cannot add info therefore can only use the trial.
-I tried uninstalling and reinstalling. Nothing.
-I tried going through Trimble Connect. Nope.
-I tried to unauthorized old license and add new one on 2018 Pro

No one else is using the license. He is the only other person and has no idea how to use it and hadn’t downloaded it to his computer let alone installing it.

I am on a HP Notebook with Windows 10. I have a presentation Tuesday so will be using 2018 Pro for now.

Any help would be appreciated. Thanks!


When you installed SU2019 on your computer, did you right click on the downloaded installer file and choose Run as administrator? If not, quit SketchUp and do so. When presented with the option, choose Repair.

Then try adding the license again.

In the meantime, the trial gives you access to the full features of SU2019 for 30 days so it would work for a presentation on Tuesday.

Thanks! I’ll give it a shot. I hate Windows but it was my only option.

Dave’s solution may work, but something else to watch out for is the license you have been sent, and whether it’s for the version you are using.

The first letter of the serial number tells you what release it is. The rest of the serial number is the same.

QA-123456-789 could be a serial number for SketchUp 2015. RA-123456-789 would be the 2016 update to that license.

If you are using SketchUp 2018, and you are sent UA-123456-789, that is a 2019 license, and won’t work. Either update to 2019 and use that license, or ask admin for a 2018 license.

There is a matching authentication code for each release, and that is quite different from the previous versions. You need the serial number that matches your version, and the authentication code that matches the serial number.

It’s a UN serial number for a school or nonprofit. He forwarded me the email from Sketchup saying we should download Sketchup Pro 2019, with a link, and enter license. I tried that but the license button doesn’t function. As I stated above, I tried to uninstall and reinstall (a couple times). 2019 Pro works but only in trial mode and won’t let me enter the license. So, I am using 2018 for the moment. I had to reinstate the 2018 Pro license to make it work again but it is working.

You would have to have a Trimble ID. If you do not have one or can’t remember if you signed in with a Google account, try to log out and then back, logging in. This would give you the option to create or set the password again if you can’t remeber it.


Did anyone manage to find a solution to your issue. I am having the same problem. When I click on the add licence button, nothing happens.

I have also reloaded as administrator and repaired the application.

The issue you are refering to, is almost 5 months ago and is probably solved for the OP.

In order to solve your problem, you would need to give some more info:

What exactly did you buy? From whom? When?

1 Like