My 2018 Pro License does not work

I purchased a 2017 perpetual version of SketchUp 2017…it recently updated to version 2018. I keep receiving a message that states that my 30 day trial has ended. I have authorizations codes, passwords…nothing works.

I contacted Technical service three time with no response. Is there a work around? I am losing business…

Thank you,


Did you get new Authorization code and serial number for SketchUp 2018? The license key and serial number for SU2017 will not work in SU2018.

SketchUp licenses are version-specific. Your 2017 license will not work on 2018, it simply never expires for 2017.

Yes, I used the new license number.

Did you install SketchUp correctly using Run as administrator after right clicking on the installer exe?

Did you run SU 2018 as trial before receiving your new serial number and license? If you did and it expired, there may be some file or registry key you need to clear to get it going again. I’m a Mac user, so I don’t know what/where that is on Windows.

As a short term workaround while you get this sorted, you can still run SketchUp 2017 using your old license number - hope you can find it!. If you uninstalled 2017 (which isn’t necessary, versions are independent and can be installed at the same time), you can download a fresh installer from the Trimble site Download All | SketchUp.

I cannot be sure…however, that is the path that I typically use when downloading programs. I simply cannot imagine that I followed a different path but I cannot remember back that far.

I may remove the program and then try to reinstall it…or bad idea?

Thank you for your help thus far, much appreciated!


I don’t know that it’s a bad idea. Before doing that I would be inclined to download a fresh copy of the installer, right click on it. Choose Run as administrator and then when presented with options, choose Repair.

I’ll give that a try…maybe in the am…long drawing day. Thank you! I am not a technical wizard for sure so I appreciate the guidance.

Good luck. Have a good evening.

Thank you!

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.