Cannot Launch SU2017

win10
crash
startup
hd4600
windows10

#1

Hi there. Have been using SU 2017 successfully for a few months. Now I suddenly can’t launch the program. Keep getting Bug Splats. I have Intel Driver 4600. Is this the wrong driver? I see from others’ posts that perhaps I should have version 4061 but not sure how to get that version. Thanks for any advice.


#2

Driver or Intel model HD 4600 graphics ?

What is your current driver version ?

NO, we said 4061 or higher.

There are direct links to Intel drivers in this pinned thread:


#3

Your recent problems may stem from recent Windows 10 automatic updates.
Some users report that reinstalling their graphics driver, after these updates fixes things.
(Apparently these Microsoft updates are messing up some graphics settings.)


#4

Hi again. Appears my Driver is: Intel 20.19.15.4360, 2160 MB memory. I’ll follow the rest of the info you provided (or I’ll try to at least!). Hopefully I’ll be able to figure this out. Many thanks in advance for your help.


#5

That should be new enough.

You can try to uninstall it, and then reinstall it. Some users have had success, apparently the recent Win10 updates had messed up some graphics settings.

OR, like I said try and install a newer version from:


#6

I downloaded the driver Intel recommended: 10.18.15.4256 - but SU still won’t launch. My system tells me there’s a newer driver available but that one wouldn’t allow SU to launch either. I’ll keep trying to find a solution. I have no idea how to uninstall and reinstall!


#7

Okay, figured out to uninstall graphics driver and reinstall. still can’t launch SU. Tried to download the driver from link provided (Intel HD Graphics 4600) but get message that have to go to my PC mfg to download driver; did that several times already today.

When trying to launch SU, get Bug Splat message that says: We are currently investigating this crash.One possible workaround for this crash is go to Control Panel > Add/Remove Programs. Uninstall all versions of Microsoft Visual C++ 2015 Redistributable. Then reinstall SketchUp.

Is it safe to uninstall all those C++ files? I have a lot of them (no idea what they do). Afraid what will happen if I uninstall them.


#8

AFAIK, you only need to uninstall the 2015 version(s) not any others. Then (for safety) reboot, and download and install the right one - see the previously referenced thread.


#9

I’m really sorry. I don’t know what those 2015 "versions are. When you say “install the right one”, do you mean the driver? And which previous thread please. There are more than one as far as I can see. Again, sorry for my ignorance on this.


#10

Control Panel > Add/Remove Programs.

Uninstall all versions of Microsoft Visual C++ 2015 Redistributable.
As, John said, leave any other versions of any other C++ Runtime editions installed.

Uninstall SketchUp.

Reboot computer.

Then reinstall SketchUp 2017, by right-clicking the installer and choosing “Run as administrator.”


Hopefully the SketchUp installer will install the latest version of the MS C++ 2015 Runtime.
IF still have same error. You may need to go to Microsoft download and d/l the standalone installer for the C++ 2015 Runtime. I give direct links in this post:

The pinned post by the SketchUp Team:


#11

Thank you so much for your help. I just spent an hour online with Geek Squad and they got it working. Essentially I think they did what you suggested in this last post. The technical lingo is beyond me! Thanks again


#12

This topic was automatically closed after 91 days. New replies are no longer allowed.