Blue axis constraint (up/down arrow) not happening


#1

Hello - I just want to move things vertically and Sketchup is being very iffy with the blue axis. It seems to be very hard to locate, and hitting the up/down arrow does nothing for me. Is this a common problem?

Red and green will show up and constrain much more readily. Any tips or tricks on how to get blue axis to show up (and constrain properly)?


#2

Blue axis constraint is now (since SU2016) just the UP arrow.

Down arrow is now constrain to plane. (If a plane constraint is not appropriate, a warning tooltip will popup.)

SketchUp’s inferencing engine was overhauled greatly for SketchUp 2016. Many bugs fixed, new nifty features, etc. If you can upgrade to SU2016, your issue may have been fixed.


#3

Following up on Dan’s point, your profile says SU 2015. Is that what you are using, or have you upgraded to 2016?


#4

Hello this is just a suggestion…I still have 2015 on my laptop and had issues like this in the past. I started using the cross hairs cursor to help get used to the inferencing engine. Manually positioning a line or object. This is not for why the Up and Down arrow keys are not functioning while the red (right) and left (green) are. That may just be your keyboard( crumbs and dust??) When I went to a wireless keyboard and mouse and ran a HDMI to my TV, to improve user-ability. The directional key constraining issue stopped by changing from the fixed keyboard. I believe I had an issue in my keyboard itself.

I can move a line or an object starting along the red axes and clicking the up arrow while moving it. It will change to and be constrained to the blue axes. All four directions function equally // the same while changing back and forth. Do you have an old keyboard laying around or someone else’s to switch and check??

I only mentioned the cross hairs because it did help me when working with arcs and getting used to the inferencing engine. But that was for manually moving between axes and not the directional keys.


#5

@DanRathbun, thanks for the news. @slbaumgartner, yes I am on 2015. I get to upgrade when the software gods at my job do the upgrade. Look forward to seeing how that changes things.

@mrwmrutski, thanks for the work around. Haven’t tried it yet but will keep it in mind (again, a run to the tech guys in my office for that).

Thanks all for taking the time to respond to my question!


#6

I’m having the same issue with the blue axis. I’ve been using SU 2016 for a couple weeks and haven’t had this problem until tonight. I think the up arrow is triggering the plane constraint instead of the blue axis constraint. Using the down arrow always says “constraint not appropriate at this time”. Anyone else having this issue? I’m pretty well stuck on all of my Sketchup projects until I can move objects vertically. Please help. Thanks.


#7

UPDATE: I just realized that not every object in my model is unmovable in the blue axis. It seems to be isolated to when I am moving a whole group only. However, an object downloaded from the 3d warehouse moves vertically just fine .??


#8

Is it possible that those objects are components with glue-to set?


#9

An easy way to check that is to right click on a component you can’t move and see if the Unglue option is available.


#10

Unglue option worked for me. I have Sketchup 2017 and the unglue option was available (right-clicking on the group). I clicked unglue and that solved the problem.


#11

Just learning how to use sketchup. The thing that is causing me to waste HOURS, is the inability to move objects on the blue axis.

Hey, SketchUP folks. Can you please explain why this seemingly simple operation is so difficult?

Here are the steps I’m doing:

Click arrow tool.
Select Object I wish to move.
Select Move tool.
TRY & TRY & TRY & TRY to move the object on the blue axis. Sometimes it works but more often than not it wants to go green, red or black. IT IS MAKING ME INSANE? Anyone know if Rhino has the same problems with such simple tasks?

And to all of those who keep saying to use the arrow key, THAT DOES NOT WORK so please stop suggesting it. It’s mean to post a solution that does not work. Why gaslight the newbies?


#12

What is the object you’re trying to move? Be specific. Share your SketchUp file so we can see exactly what you are trying to move in the blue direction. Most likely, it’s a component that was given gluing properties.

Why the attitude in your first post? If you want help, don’t start out by insulting those who would try to help you.


#13

the arrow key will fail on a component if it has a ‘glue to’ property set…

john


#14

Here is a recent post pertaining to using the move tool.

Included in the post is an explanation of how moving works as well as a video tutorial


#15

Thank you! Solved it!