New User: Why won't push/pull snap to blue axis like in the tutorial?

pushpull
snap
help
blueaxis

#1

Hi! I’m Aaron, a new Sketchup user.

Just was going through the very first tutorial: Getting Started With Sketchup - part 1 http://www.sketchup.com/learn/videos/826

And already noticing a difference in how my Sketchup works than the one in the tutorial. When he push/pulls the edge of a “roofline” to create a simple gable roof, his push/pull snaps to the blue axis. However, when I do it, I’m left free-floating to eyeball how straight my roof is; there’s no snapping happening to the blue axis.

Anyone know what the issue might be? And how I can fix it?

Running latest Sketchup on Mac 64 bit, literally just installed it today.


#2

Hello. Welcome to the community. :slight_smile:

He doesn’t Pushpull it, he uses the Move Tool. They’re different.

If you don’t seem to be able to move the roof line upwards, first adjust your view camera position to something more comfortable and try again. Hint - if you get the blue axis snap you can hold down the Shift button to lock your movement to that axis. You’ll notice that your blue path becomes slightly thicker, implying that you’re locked to that particular axis.

If you’re still unable to snap to that axis, I’d suggest hitting the Alt key once to enable Auto-Fold, which basically gives you a bit more control in your edge movement.

Oh! One other useful hint. Go to System Preferences > Drawing and enable the Display Crosshairs checkbox.

This is a very useful feature and it can help you understand where the RGB axes are in perspective. For me it’s always turned on.


#3

@VahePogossian Thanks for your reply. Sorry, I misspoke. I meant the (M) Move Tool, which is the one I was using, just like in the tutorial.

Unfortunately your initial thinking – that I was misunderstanding the camera position – didn’t help. Neither did holding Shift, which I tried earlier already.

Let me post screenshots to explain.

According to the tutorial, I should be getting that dashed vertical line to turn blue and a little dialog box should say “On Blue Axis”, like so:

However, when I select I select the edge, like so…

----forum won’t let me post images of my problem to get help, brilliant----

Instead, I get no snapping of that dashed line to the blue axis where the tutorial is telling me I should expect it to snap to. Like this:

----forum won’t let me post images of my problem to get help, brilliant----

Having worked in other softwares, this feels like a Settings or Preferences issue, but I just don’t know enough about SketchUp yet to troubleshoot this on my own. :frowning:


#4

This is what happens for me instead:


#5

This is without touching any keys.
You probably just need to get familiar with how the camera angle affects how you can move things in 3d space.


#6

@Box I totally see what you’re doing. Same steps I took. The ONLY difference is that when I “raise the roof” using Move my dashed line is not blue and I do not get the “On Blue Axis” message no matter how much I move it around or try different things.


#7

Since you are using SU2017 you can tap the up arrow to lock to the blue axis.


#8

I tried uploading a video like you did to demonstrate my issue is actually an issue, but I received an error message saying the file is too big to upload. :frowning:

@Box Yes, the up arrow does work, thanks for that! But I shouldn’t have to do that for each axis I want to snap to, should I? That seems terrible for workflow.


#9

No, not at all. It’s just another way of achieving the final result. By the way, If you need to provide short animated GIFs like Box did, you can try ScreenToGif software which is free and easy to use.

Going back to your problem, did you try the Auto-Fold technique that I mentioned? Through the screenshot that you provided I can see that its trigger key is Command for MacOS.


#10

@VahePogossian I would use ScreenToGif, but I’m running OS X and it is for Windows Vista. Hmm. Let me try Recordit.

What you can see here is me trying, in this order:
SHIFT –– nothing happened
ALT –– Oops! my bad!
COMMAND –– Auto-Fold worked, but it also created unwanted lines in the image, and may have actually modified other connected surfaces


#11

I’m sorry. I forget to check OS compatibility before posting.

This is strange because it doesn’t produce additional geometry by me. You can see I hit the Auto-Fold modifier there while dragging the line upwards.


Overall, this whole thing is strange. Can I ask you one more thing? Let’s forget the whole house concept and go flat. Can you reproduce this?

If it still won’t let you snap to blue axis, I’ll risk, go ahead and have the audacity to ask you to reinstall SketchUp because I can’t possibly think of anything else.


#12

@VahePogossian What do you know that worked (without need Auto Fold at all). And it worked again when I recreated the “house” from scratch. Dashed line lit up blue just like the tutorial and your video clips. I…I’m at a loss…

All I can think of is that I inadvertently changed the geometries of the “house” in some way that messed with snapping? :confused:

Anyhow, thanks Vahe, much appreciated.


#13

You’re welcome. :slight_smile: Let us know if you have problems in the future. And good luck with SketchUp. :thumbsup: