Black screen on Sketchup Pro 2018


#1

After installing/updating to the new 2018 Pro I get a black screen. I have a Dell XPS15 with a Nvidia GTX 960M grapich card.
Anyone with a solution to this?


#2

Did you try updating the graphics drivers? Does the computer also have an Intel graphics adaptor? If so, make sure the Nvidia card is set up as the default.


#3

Updated the Geforce driver and set the settings to force use this driver. Not sure why this was a problem with 2018 and not on the 2017…


#4

Change in graphics requirements.

Each version of SketchUp installs separately, too.


#5

Hi, Same problem.
Fixed. (Windows)
Go to control panel/nvidia control panel/manage 3d settings
I left my Global settings on auto select.
On the Program Setting tab I selected SU as the program to customise - don’t forget to click Apply.
Rebooted SU.


#6

OP is a laptop user. NVidia laptop-users (at least) have a convenient shortcut. Try r-clicking on SU18 desktop icon and select the option which allows one to chose preferred graphic card to be used for the program. Otherwise, as @Yorg wrote, r-click on empty desktop space and choose NVidia Control panel > follow rest of step outlined above.


#7

I think that is a Windows 10 feature. Not in Windows 7.


#8

For those like me who had a similar issue but wasn’t able to solve it based on the other comments, try reducing the multisampling and turn off fast feedback on sketchup through window>preferences>OpenGL


#9

This was the solution for me. I tried to open sketchup, the work screen was black, I clicked on windows, clicked on preferences, clicked on open GL and unchecked use fast feedback and as the little girl on the commercial says Waa Laa. I have windows 10 and it uses Intel 64-bit Hope this helps someone else as it did me. Thanks all who helped me get it done.:sunglasses:


#10

Joseph,

Would you mind posting your system’s OpenGL details?

You can find this info in SketchUp by going to Window > Preferences > OpenGL > Graphics Card Details. I’m particularly interested in the graphics card model and driver version.

2017-12-07_12-38-17

Thanks,
Mark Chandler


#11

vendor: IntelRenderer: Intel ® HD Graphics 620GL Version: 4.4.0-Build 21.20.16.4639
Pixel Format DBL RGBA: 8-8-8-8 Depth:24 Stencil:8 MSSA:4 FF:0
How did you copy paste that?

Best Regards

Joseph

785-840-8280

mchandler SketchUp Team Member
December 7 |

Joseph:
This was the solution for me. I tried to open sketchup, the work screen was black, I clicked on windows, clicked on preferences, clicked on open GL and unchecked use fast feedback and as the little girl on the commercial says Waa Laa. I have windows 10 and it uses Intel 64-bit Hope this helps someone else as it did me. Thanks all who helped me get it done.

Joseph,

Would you mind posting your system’s OpenGL details?

You can find this info in SketchUp by going to Window > Preferences > OpenGL > Graphics Card Details. I’m particularly interested in the graphics card model and driver version.

Thanks,
Mark Chandler

Visit Topic or reply to this email to respond.

In Reply To

Joseph
December 7 |

This was the solution for me. I tried to open sketchup, the work screen was black, I clicked on windows, clicked on preferences, clicked on open GL and unchecked use fast feedback and as the little girl on the commercial says Waa Laa. I have windows 10 and it uses Intel 64-bit Hope this helps someo…
Visit Topic or reply to this email to respond.

To unsubscribe from these emails, click here.


#12

Thanks for posting your system’s info.

You can upload a screenshot (or other image) using the upload button.


#13

Hi, Same problem here…

I went to the control panel/nvidia control panel/manage 3d settings, changed my settings to be Global settings on auto select for SU, Rebooted SU.

Also unchecked the Use fast feedback box and reduced the multisample to x2…

I Still get a black screen only after 2-3 minutes of simple work.

Can anyone help me please?
Thanks!


#14

@KaMo, don’t rely on Global settings for SU. Global refers to what may be used as default for all programs. You are on a laptop? As you are on Win10, try r-clicking on SU desktop icon. One of the context menu options will be about graphics performance. Pick your NVidia card to be used for SU. You want the highest performance option for SU.


#15

You could also try updating your Nvidia driver. The one you have is from early fall, the newest was released ten days ago.


#16

Tried everything you said… also updated my NVidia driver, tried the 2017 version and my screen still turns completely black after 2 minutes …


#17

You mean the whole computer screen, not only the inside of your SketchUp window? The only time I have seen this was when a graphics card in my old computer failed. It first started blacking out in SketchUp (logically, as it taxes the GPU much more than other applications) but afterwards it started failing in other applications too. So a hardware fault is also a possibility. Is the cooling system in your PC and on the graphics card functioning normally? The Nvidia control panel has also, if I remember right, a function to monitor the operating temperature.


#18

Following @Anssi hardware concerns, a completely black screen could also mean a monitor is going bad which recently happened to me. Other bad monitor symptoms included monitor driver reloading and the screen display restored and once even got a BSOD. Reportedly a recent Windows 10 update has also affected a few monitors using NVidia cards though graphic driver update fixed that issue for many of those people. Are you referring to the entire screen or just the SU workspace?

Speccy is a free app from the developer of CCleaner that provides a detailed review of your computer including temperatures of different hardware components.


#19

Sorry for the confusion, i meant the SU window only (i can still see the tools and everything else). This is a brand new laptop I am starting to think that there is something linked with Windows 10…


#20

That looks like a graphics driver issue. Did you check with the NVidia site for a driver update instead of relying on Windows update?

In SU, when you go to Window > Preferences > OpenGL > Graphics card detail, does it say you are using the NVidia card?