SketchUp Pro 2018 Install Issues

After Upgrading to SU Pro 2018 the main screen is black/blank. Anyone know the resolution to this issue. Layout and Style Builder work as normal.

I see you have a laptop. First check that SU is indeed using your NVidia card. In SU go to Window > Preferences > OpenGL and click on the graphics card detail button. If you are using the NVidia card, then go to the NVidia site to get the latest driver.

If you are using the Intel graphics, you need to change which graphics is used with SU. Try r-clicking on the desktop icon for SU, there may be a shortcut to pick the NVidia card in the context menu.


Thanks - I had the same problem and your response solved it for me!

Thank you this is the solution. It made no sense that 2017 worked one minute and then 2018 didn’t following installation. Why don’t they build the graphics card switch option into the preferences menu?

You can also try turning down the multisampling and disabling fast feedback, also found window>preferences>OpenGl

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.