Sketchup Pro 2018 launch Issues

I have sketchup 2017 Pro, and I am planning to upgrade to SU Pro 18,
I downloaded the trial version and when I load / run / open it, i get a black screen instead of the familiar white screen, and I can not see Stacy or even draw a line, as all is in black, SU pro 17 still works in the same computer. Any one having this problem, I wrote to techinical support and they said driver may need update, I checked both at ms windows and intel, I have the most current driver,
I am attaching a screen image of what I am getting when I open SU Pro trial 18
any help/ suggestion would be appreciated. I am using windows 10 home with 8 ram and 45 gB free space on the machine

Two things to try no matter what.

  1. Make sure you installed SketchUp correctly by right clicking on the installer file and choosing Run as administrator. If you didn’t do that, SketchUp is not installed correctly. Do it now and choose the Repair option.

  2. Update your graphics drivers. What is your graphics card? Your profile doesn’t say.

answering q.2, my graphics card info :


for q1. i believe i did it properly as this was after my second attempt (ie. install, unistall and reinstall) but will try again with repair option, do not think i tried repair option

also it is an intel core i7 processor

Make sure you right click on the EXE file and choose Run as administrator.

I tried all the options, as administrator and also repair option, still does not work, i get the same black screen

There may be a newer driver available for your graphics card.

Have you tried updating the driver using Windows’ Device Manager?

I did update the drivers yesterday and it is still not working. I contacted SU, they called today to let me know they are having issues with the intel 5 series graphics driver (??) and are working on it. In the mean time I am still waiting,
Is anyone else having an issue then please let SU know.

I have the same problem. I’ve installed after a clean re-boot and launched as Administrator. I’ve got the latest NVidia drivers as well, I just updated this morning. Here is a snapshot of my system:

If you right click on the Sketchup 2018 icon, do you see an option to use the nvidia gpu?

Shep

Shep,

You went down the path that I was beginning to investigate after I ran the Sketchup 2017 install checker. It indicated that the default graphics card (Intel HD 630) did not have enough memory. So I started investigating why in the world the default graphics card would be set to the integrated graphics of the processor and apparently Dell sets it that way for power management while on battery. My first inclination was to disable the graphics card entirely in Device Manager but I didn’t want to go down that road until I created a Restore Point and did an image backup. So I’ve gone through the NVidia settings and set the default settings on a number of programs to the NVidia card.

Long story less miserable, yes setting the graphics card to the NVidia driver fixed the problem.

Thanks!

It is the same with all Windows laptops if you let Windows decide. Application settings in the Nvidia control panel default to “Automatic selection” or equivalent, and for some weird reason Automatic always means Intel.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.