Sketchup 2018_extremely slow, flickering, black screen

hi. I’ve been using sketchup pro on my 16GB PC for a long time but recently, with the new SU 2018 I’m having a big problem:
with any kind of command (move, stretch, etc), all of a sudden the contents of “Outliner” window starts to flicker, than the screen becomes all white while the cursor acts as it is loading (blue, round and spinning) and finally the screen becomes all black and it takes even ten minutes until I’m able to work again. could you please tell me wht’s wrong or what i’m doing wrong?

you’ll find one file as example at:

thanks for any help/suggestion you’ll give me.
best regars,
betta

Very likely the problem is related to your graphics card and its drivers. In SketchUp go to Window>Preferences>OpenGL and untick Use Fast Feedback. Does that help?

Please complete your profile with the model number of your graphics card and SketchUp version.

It’s probably not the cause of your display issue (I agree with @DaveR that Windows 10 probably installed a bad update to your drivers), but I notice that the chain hanging the lamps in the kitchen is quite “heavy” with a lot of edges and faces for what it contributes to the model. You might want to try simplifying it.

I tested this model on an entry level laptop with a dedicated GPU and it was smooth, what video card do you have? I have heard of this issue before with integrated Intel GPU’s only.

thanks! these are, I hope, infos about the video card running on my laptop:

Intel® HD Graphics 620

Report Date: Monday, March 4, 2019
Report Time [hh:mm:ss]: 6:44:08 PM
Driver Version: 21.20.16.4550
Operating System: Windows* 10 Home (10.0.17134)
Physical Memory: 16264 MB
Vendor ID: 8086
Device ID: 5916
Device Revision: 02
Graphics Output Protocol (GOP) Version: 9.0.1048
Current Resolution: 1920 x 1080

Processor: Intel® Core™ i7-7500U CPU @ 2.70GHz
Processor Speed: 2904 MHz
Processor Graphics in Use: Intel® HD Graphics 620
Shader Version: 5.1
OpenGL* Version: 4.4
OpenCL* Version: 2.1

does it help?

betta

As I said before, integrated Intel graphics such as yours often have problems with adequate OpenGL support. And because Microsoft frequently pushes graphics driver updates that break things, it can work one day and the next it doesn’t.

Did you follow my suggestion?

I’m trying now, I’ll let you know asap.

thanks!

Yeah, if it was a desktop a simple solution would be to drop in a gtx 10 series GPU and all would be solved, but it’s a laptop and I’m not even sure one can add a dedicated GPU.

I’ve unticked the “Use Fast Feedback” but still the problem is the same :frowning:
any other suggestion? I’ve purged the file even with cleanUp in order to keep it light and have no more ideas…
B

I suggest having the Outliner panel in it’s own tray, and this tray collapsed into the left margin so it is not open when moving objects and editing the model. (This is also called “unpinning”. First create a new tray named “Tree” or whatever you like, then assign the Outliner panel to it, and dock this new tray to the left margin. Lastly click the pushpin button in the upper right of this tray’s caption bar to “autohide” it into the margin.)

Then when you really do need to use the Outliner, just hover the mouse over it’s margin tab and the panel will slide out into view. You can use, expand objects, and select things, etc. … and when you move the cursor outside the tray window, it will slide back out of view automatically.

Yesssss! much better! looks like you’ve given me the solution! actually I’ve started to have this problem since I’ve discovered the outliner…
thanks!

b

1 Like

The updates to Outliner panel data can drastically slow down SketchUp.


See also Help Center article …

Ah, you had outliner open, I never use outliner as it causes more issues than it solves, I also disable auto save as it too can cause issues when working with heavy models, got into a habit of saving before executing any plugins, glad you are sorted out.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.