Sketchup Pro 2018 Slowest booting with constant blackouts


#1

12 year veteran of Sketchup here. In the last 6 months, I upgraded to a gaming laptop for faster operation. Very slow to boot and screen is constantly whiting or blacking out, which seems to coincide with the autosave cycle. Seeing the (program not responding) message dozens of times a day as I work now.

In short, I’ve spent more money and time than ever before to optimize my workflow, but the end result is the slowest booting, worst crashing version of Sketchup. NEVER had these problems previously. Is it all Windows 10 related?

In searching for similar threads, not seeing much current discussion, so I’m lost for a solution. Have tried some suggestions regarding OpenGL settings, such as fast feedback/ unchecked maximum texture size. Just cannot pull it out of this funk.

Am I alone in this?


#2

What are the detailed specs of your laptop and monitor setup?


#3

Is SketchUp actually using your Geforce GTX card? If your Window menu>Preferences>OpenGL shows that it is using an Intel integrated chip, you must change the 3D application settings in the Nvidia control panel to force SketchUp to use the Nvidia (the “OpenGL rendering GPU” setting). Also make sure that your Nvidia driver is up to date (I just got a new work computer, and the Nvidia driver it shipped with was more than a year old).


#4

HP Omen Corei7 processor 2.8 GHz
500gig SSD drive, 1T Disc drive
8 GB RAM
1920x1080 screen resolution, integral 4k display


#5

Confirmed, Geforce GTX has always been set as graphics card, as shown in the OpenGL Settings.
Just performed another driver update attempt, and have again received message that driver is current and up to date.


#6

Windows does not always provide the latest drivers. Go to the Nvidia site and get the latest drivers for your GTX


#7

Well, can’t hurt, as I see the latest version for the 1050Ti was updated Oct 10, 2018.
520MB file:astonished:, so it will be an hour or better before it can be installed.
Sure glad I’m on a hard line here…


#8

Installed updated graphics driver from Nvidia. Sketchup is repeatedly opening almost instantaneously now, and in the couple hours I’ve used it so far, no blackouts / whiteouts.
Of note: Sketchup support team was contacted as well. They had me download a program this morning called “Checkup”, which scans computer for compatibility with Sketchup 2018. Ran this after updating driver last night, and it claims my computer is 100% compatible. Not certain whether this app would have detected a dated driver for graphics card, but nice to have verification of some sort.

Big thanks to all for suggestions, especially pushing me to dig further on the driver updates, as I never would have guessed this was the issue, nor realized Win10 was not 100% correct in it’s assertion that I was using the very latest drivers.

Hope others reading this will find these results help them eliminate similar issues all the quicker…

Cautiously optimistic that all is good now. Any further issues will likely reveal themselves in the next 24-48hrs, and I’ll report back accordingly.

Thanks again,

Jeff


#9

If you install the Nvidia GeForce Experience software, it can be configured to download and install the latest driver updates.


#10

Today I suddenly have 5-7 minute load time on a large model I’ve been working on for months. Worked well 2 days ago. Trying to isolate what I did that could have triggered this. Things work fine once loaded, but a very unnerving concern if it ever would. Split the model in half, and now only wait about 2 minutes, but still, this is crazy. Again, poking around in all kinds of ways to purge unused components, no shadows, regroup excessive geometry into separate layer and hide until after loading. Checking system performance - processor reads 98% INactive, ~50% memory use as it sits, struggling for minutes to open a file that was fine just a few days ago. No new 3D warehouse downloads… I grow weary of this constant degradation of sketchup performance. Thoughts?


#11

File is still on your SSD?


#12

Also, check out what your GPU is doing during a model load in your task manager details (add columns).

Check if your GPU driver has changed, if necessary.


#13

File is still on SSD. Concerned I really got off to a bad start with this machine, as it was putting everything on the SSD as I was loading programs etc,. from previous machine. Didn’t realize it was doing so until it was full, then had to back a ton out and get it on the storage hard drive, where most of it belongs.
Since it was configured to place everything on SSD, ( errantly assumed it was supposed to be automatically allocated to be reserved for Windows operations, period) all my current work on desktop is being stored there. Once archived, it gets moved to hard drive.


#14

CPU is working while waiting to load, but GPU is flat -0- zero until the model appears on screen.
My Task manager is a bit different, in that GPU stats do not appear under “details” as your screen shows.
I’m viewing “processes” tab in order to monitor this activity. I see nothing indicating “dedicated GPU”, but it does appear as GPU 1-3D in a column in the “processes” tab. As I type this, looks like GPU 0 - 3D is working on running the browser, while GPU 1 - 3D is assigned to Sketchup Application and only responds when I’m active in sketchup. I read this as the Nvidia GEFORCE GTX graphics being properly assigned as the graphics driver for Sketchup. Also tells me it is not this graphics card delaying the loading process. Main CPU is chugging at about 35% as the model is loading.


#15

As you’ve likely guessed, this is the first time I’ve used a machine with multiple hard drives. Also, first time with multiple graphics drivers. Feels like I’m missing a simple assignment in program configs that is causing the machine confusion on just how to load things. In Sketchup Preferences, File Locations, Models and Exports are assigned to SSD as current work is running off it. Remainder (components, Materials, etc ) are assigned to what I consider archives, which is the secondary, conventional hard drive. Have I simply made a big mess of things running with this configuration?


#16

Another issue to check is your NVIDIA PhysX configuration - this is something I have been trying to resolve with NVIDIA myself in recent weeks. Located in the NVIDIA control panel, beneath the 3D settings, it will indicate which graphics chip is running your monitor - just 1 monitor?

(Unfortunately, with laptops you can get situations where the dedicated GPU runs the 3D software, but the Intel GPU runs the monitor, causing poorer performance, which the PhysX configuration will confirm).


#17

Changed PhysX settings from Auto to the GeForce GTX 1050 Ti.
Indeed, I added an LG superwide external monitor a month ago so I could more easily navigate several programs at once. Noticed at jobsite drafting yesterday, it seemed to load at a normal pace there, though I am connecting to a wall mount television for ease of collaboration with designer. TV drives itself, so GPU is untaxed in that setting.
So - something I can correct while utilizing an additional external monitor, or is the card not capable of running the two?


#18

Changing the PhysX setting to the GeForce GPU does not necessarily change the GPU function - can you upload a screen capture of the PhysX control panel now with 2 monitors connected.

I had to back date my NVIDIA driver for my older GPU to get the best performance with SU.

Other issues here include HP will have specific drivers of their own for the Intel and NVIDIA GPUs.

It may be your Intel graphics driver is most at fault and auto updated by WIN 10 Pro?


#19

Looks like Nvidia is dedicated to outboard monitor, and Intel is not recognizing it, though I’ve hit the “detect” button to do so.


#20

Trying again - split up for legibility:

Intel Graphics screen

Seems each has taken a screen and one will not recognize the other.