Sudden black screens

Hello,
I am using Sketchup Pro 2019 and I get random black screens that last a few seconds. Really annoying. What could be the problem?
I am using a Lenovo Legion Y530-15ICH with the following specs: Intel i7-8750H, GTX 1050Ti. 16GB 2666Mhz RAM, and the storage is dual: 1TB 5400RPM HDD and 128GB NVME SSD

Update graphics driver direct from Nvidia.
Also check Lenovo to see if there are any BIOS updates.

Is it the entire screen that goes black, or just the modeling area ?

Also check in the Nvidia control panel 3D application settings that SketchUp is set to use your Nvidia card instead of the Intel UHD graphics inside your CPU:

1 Like

Everything is up to date, and the black screen is only on the Sketchup window but not all of the screen. I also checked that SketchUp is set to work on Nvidia gpu

Can you post a screenshot image?

1 Like

Something that could have happened, and that would give similar symptoms, is if the Intel GPU was in use at the time that SketchUp 2019.3 was installed. If that was the case the Use fast feedback option would have been turned off. Check in Preferences/OpenGL to see if that is checked on or off.

3 Likes

I will try it soon and I’ll update with screenshot, it’s just that the laptop is not with me now. Could it be that the dual graphics is causing this issues? I had a laptop with dual graphics which also caused problem in the past. Maybe it’s just not suitable? Does any of you have experience with laptop with dual GPUs?
*Edit: I disabled the 1050Ti in device manager, just to see if these black screens are caused by it, but they still occur. Do you still think it’s Use fast feedback?

**Edit 2: You said that Use fast feedback would’ve been turned off, but other forum threads with similar problem suggested to turn it off, and you say that I should turn it on?

I have once, in the Windows XP times, had a graphics card failure, and the symptoms started with black SketchUp screens, and afterwards black screens in all applications. So a hardware reason is not quite impossible.

1 Like

Was it a desktop or a laptop? Darn,mine is quite a new laptop… could it really be the problem? Also, any of you have an experience with MSI Afterburner to ask some question regarding this problem?

One more thing: When I open files, it displays black screen, says not-responsive in the bar, and after 5-10 minutes it opens … Is it normal for an i7-8750h to open a Sketchup file that slow? Should it take that long? Also, when downloading stuff it always turns the Sketchup window into black for a few seconds… I turned off Fast feedback with no help

Unless the model is immensely detailed (millions of edges and faces), no it is not normal to take that long to open.

No, I have a MSI GP63 Leopard which is close to your specs. (it has a GTX1060.)
I do not overclock and do not have Afterburner installed. I do not ever have black interrupted modeling area.

I suggest resetting your CPU to factory defaults. And then see how SketchUp works.
Disable Afterburner if you need to.

I reset everything and it’s still the same… maybe I’ll format my PC entirely it’s been giving me troubles. Will also fresh install the GPU drivers

The turning use fast feedback off is the cure for problems seen especially on Surface Pro. Later versions of 2019 turn that off if the installer sees that you’re using an Intel GPU, but if your GPU is better than the ones in Surface Pro, it’s quite likely that the GPU is powerful enough to cope with use fast feedback being turned on.

So yes, if you see artifacts when use fast feedback is turned off, try turning it on.

What!? This will not help. If the machine has Intel hardware, Windows will just reinstall the drivers again from it’s library of WHQL drivers (which will not likely be the most up to date.) To prevent this, the integrated GPU would need to be switched off in the BIOS. (However, I’ve read that this should not be done for mobile CPUs.)

Interesting, I did not know that. Thanks for the tidbit.