Add License buttons do nothing in 2016 Welcome dialog

Good Afternoon All,

I’ve bought the student license for sketchup 2016 and can’t get the license to work. I went to the help site and tried to contact Trimble, just keep getting a message that says the site is messed up not accepting messages. I need sketchup to work and can’t get the license screen to show the space for my authorization code and serial number to input. Does anybody have any idea how to fix this?

What happens when you click on Add License?

Nothing. It doesn’t go anywhere, no page tries to load, no box appears.
Literally nothing. I’ve completely uninstalled and reinstalled at least 5

Have you used SketchUp with more than one monitor?

I can’t remember a specific instance but most likely yes.

How do you feel about editing the Registry?

Try pasting it in when you click on Advanced.

There is no advanced

Click “Add License”…

Nothing happens as per the screenshot

I’ll do it if you’ve got a step by step but I’m not computer literate
enough to do guesswork unfortunately.

Did you try both “Add License” buttons? (aside - I’m not sure why we have TWO buttons there).

You’re Windows (what version) right? Can you click in that window, and type Control-L and get a url window to pop up?

Might be worth checking that Internet Explorer is up to date and not blocked.


I’ve tried both add license buttons, Control l does nothing, what do I
need to do to make sure IE isn’t blocked? I don’t use Internet Explorer

You may not use IE but SketchUp does. Make sure it is up to date and that the security setting is not too high.

Aye aye sir. Side note: why do industry companies use IE? It is such a
garbage program

They do it because they can be assured that the Windows operating system will include it. The same for using Safari on Macs.

If they chose something else for web dialogs, people would complain because they don’t have that browser installed.


Despite what you think of it, IE is the standard for windows and Safari for Mac.
If SU used another browser you would have to make everyone install it.
If people are up to date with the defaults then it works.
Dave is on point and i’m slow on my phone.

1 Like

It’s behaving like the window isn’t front / key. Can you switch to the other items (Learn, Template)? I don’t have a 2016 expired on Windows right now, but I have 2015 expired on Windows, and I can click on those things. Another way to get rid of a key window if the license window is not key is Alt-F4 (closes current key window).